CVE-2021-39137 Consensus flaw during block processing in go-ethereum

Medium 6.5 Published Updated

A consensus flaw in go-ethereum can cause a chain split, leading to denial of service for nodes running vulnerable versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39137?

CVE-2021-39137 is a medium-severity vulnerability in go-ethereum, published on 24 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

go-ethereum is the official Go implementation of the Ethereum protocol. In affected versions a consensus-vulnerability in go-ethereum (Geth) could cause a chain split, where vulnerable versions refuse to accept the canonical chain. Further details about the vulnerability will be disclosed at a later date. A patch is included in the upcoming `v1.10.8` release. No workaround are available.

Weakness: CWE-436

Which versions are affected by CVE-2021-39137?

3 open source packages ship an affected version, including github.com/ethereum/go-ethereum. It affects 1 product.

PackageAffectedFixed in
github.com/ethereum/go-ethereum GoAll versions1.10.8
github.com/ethereum/go-ethereum GoFrom 1.10.01.10.8
github.com/ethereum/go-ethereum GoFrom 1.10.01.10.8

Products include Ethereum Go Ethereum.

How do I fix CVE-2021-39137?

Upgrade github.com/ethereum/go-ethereum to 1.10.8 or later.

Is CVE-2021-39137 being exploited?

There is no known exploitation of CVE-2021-39137 in the wild and no public exploit code.

Sources

Also known as GHSA-9856-9gg9-qcmq, GO-2022-0254.

Is CVE-2021-39137 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free