# CVE-2021-39137: Consensus flaw during block processing in go-ethereum

> A consensus flaw in go-ethereum can cause a chain split, leading to denial of service for nodes running vulnerable versions.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9856-9gg9-qcmq, GO-2022-0254

## What is CVE-2021-39137?

CVE-2021-39137 is a medium-severity vulnerability in go-ethereum, published on 24 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

go-ethereum is the official Go implementation of the Ethereum protocol. In affected versions a consensus-vulnerability in go-ethereum (Geth) could cause a chain split, where vulnerable versions refuse to accept the canonical chain. Further details about the vulnerability will be disclosed at a later date. A patch is included in the upcoming `v1.10.8` release. No workaround are available.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2021-39137?

3 open source packages ship an affected version, including github.com/ethereum/go-ethereum. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ethereum/go-ethereum` | Go | All versions | 1.10.8 |
| `github.com/ethereum/go-ethereum` | Go | From 1.10.0 | 1.10.8 |
| `github.com/ethereum/go-ethereum` | Go | From 1.10.0 | 1.10.8 |

Products: Ethereum Go Ethereum.

## How do I fix CVE-2021-39137?

Upgrade github.com/ethereum/go-ethereum to 1.10.8 or later.

## Is CVE-2021-39137 being exploited?

There is no known exploitation of CVE-2021-39137 in the wild and no public exploit code.

## Other vulnerabilities in go-ethereum

- [CVE-2026-26314](https://insights.sbomify.com/CVE-2026-26314/): Go Ethereum affected by DoS via malicious p2p message (high 8.7)
- [CVE-2023-42319](https://insights.sbomify.com/CVE-2023-42319/): go-ethereum vulnerable to denial of service via crafted GraphQL query (high 7.5)
- [CVE-2023-40591](https://insights.sbomify.com/CVE-2023-40591/): Denial of service via malicious p2p message in go-ethereum (high 7.5)
- [CVE-2021-42219](https://insights.sbomify.com/CVE-2021-42219/): Denial of service in go-ethereum (high 7.5)
- [CVE-2022-23327](https://insights.sbomify.com/CVE-2022-23327/): Denial of Service in Go-Ethereum (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39137 and fix it if it is affected.

What it is: CVE-2021-39137 is a medium-severity vulnerability in go-ethereum, published on 24 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39137 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ethereum/go-ethereum (Go): affected all versions; fixed in 1.10.8
- github.com/ethereum/go-ethereum (Go): affected from 1.10.0; fixed in 1.10.8
- github.com/ethereum/go-ethereum (Go): affected from 1.10.0; fixed in 1.10.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39137/ (Markdown: https://insights.sbomify.com/CVE-2021-39137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39137
- OSV: https://osv.dev/vulnerability/CVE-2021-39137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39137/
Summaries are generated and may contain mistakes; the official description above is the record.
