CVE-2021-39138 New anonymous user session acts as if it's created with password

Medium 4.8 Published Updated

Anonymous users are incorrectly marked as password-authenticated, potentially allowing privilege escalation if developers rely on this field for access control.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39138?

CVE-2021-39138 is a medium-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 18 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Developers can use the REST API to signup users and also allow users to login anonymously. Prior to version 4.5.1, when an anonymous user is first signed up using REST, the server creates session incorrectly. Particularly, the `authProvider` field in `_Session` class under `createdWith` shows the user logged in creating a password. If a developer later depends on the `createdWith` field to provide a different level of access between a password user and anonymous user, the server incorrectly classified the session type as being created with a `password`. The server does not currently use `createdWith` to make decisions about internal functions, so if a developer is not using `createdWith` directly, they are not affected. The vulnerability only affects users who depend on `createdWith` by using it directly. The issue is patched in Parse Server version 4.5.1. As a workaround, do not use the `createdWith` Session field to make decisions if one allows anonymous login.

Weakness: CWE-863, CWE-287

Which versions are affected by CVE-2021-39138?

3 open source packages ship an affected version, including parse-server and parse. It affects 1 product.

PackageAffectedFixed in
parse-server npmAll versions4.5.2
parse-server npmAll versions4.5.2
parse BitnamiAll versions4.5.1

Products include Parseplatform Parse-Server.

How do I fix CVE-2021-39138?

Upgrade parse-server to 4.5.2 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2021-39138 being exploited?

There is no known exploitation of CVE-2021-39138 in the wild and no public exploit code.

All Parseplatform Parse-Server vulnerabilities

Sources

Also known as BIT-parse-2021-39138, GHSA-23r4-5mxp-c7g5.

Is CVE-2021-39138 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free