# CVE-2021-39138: New anonymous user session acts as if it's created with password

> Anonymous users are incorrectly marked as password-authenticated, potentially allowing privilege escalation if developers rely on this field for access control.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-parse-2021-39138, GHSA-23r4-5mxp-c7g5

## What is CVE-2021-39138?

CVE-2021-39138 is a medium-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 18 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Developers can use the REST API to signup users and also allow users to login anonymously. Prior to version 4.5.1, when an anonymous user is first signed up using REST, the server creates session incorrectly. Particularly, the `authProvider` field in `_Session` class under `createdWith` shows the user logged in creating a password. If a developer later depends on the `createdWith` field to provide a different level of access between a password user and anonymous user, the server incorrectly classified the session type as being created with a `password`. The server does not currently use `createdWith` to make decisions about internal functions, so if a developer is not using `createdWith` directly, they are not affected. The vulnerability only affects users who depend on `createdWith` by using it directly. The issue is patched in Parse Server version 4.5.1. As a workaround, do not use the `createdWith` Session field to make decisions if one allows anonymous login.

Weakness: CWE-863 (Incorrect Authorization), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-39138?

3 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 4.5.2 |
| `parse-server` | npm | All versions | 4.5.2 |
| `parse` | Bitnami | All versions | 4.5.1 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2021-39138?

Upgrade parse-server to 4.5.2 or later.

## Is CVE-2021-39138 being exploited?

There is no known exploitation of CVE-2021-39138 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39138 and fix it if it is affected.

What it is: CVE-2021-39138 is a medium-severity authentication bypass vulnerability in Parseplatform Parse-Server, published on 18 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39138 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 4.5.2
- parse-server (npm): affected all versions; fixed in 4.5.2
- parse (Bitnami): affected all versions; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39138/ (Markdown: https://insights.sbomify.com/CVE-2021-39138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39138
- OSV: https://osv.dev/vulnerability/CVE-2021-39138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39138/
Summaries are generated and may contain mistakes; the official description above is the record.
