{"answers":{"affected":"2 open source packages ship an affected version, including io.smallrye:smallrye-health-ui. It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-3914 in the wild and no public exploit code.","fix":"Upgrade io.smallrye:smallrye-health-ui to 3.1.2 or later.","what":"CVE-2021-3914 is a medium-severity cross-site scripting vulnerability in smallrye-health, published on 25 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-3914 and fix it if it is affected.\n\nWhat it is: CVE-2021-3914 is a medium-severity cross-site scripting vulnerability in smallrye-health, published on 25 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-3914 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.smallrye:smallrye-health-ui (Maven): affected all versions; fixed in 3.1.2\n- io.smallrye:smallrye-health-ui (Maven): affected all versions; fixed in 3.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3914/ (Markdown: https://insights.sbomify.com/CVE-2021-3914/index.md)","id":"CVE-2021-3914","markdown":"https://insights.sbomify.com/CVE-2021-3914/index.md","name":"CVE-2021-3914","record":{"aliases":["GHSA-pvc3-wvxr-7cmf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"SmallRye Health Metrics","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the SmallRye Health Metrics UI due to insufficient input sanitization, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"build_of_quarkus","vendor":"redhat"},{"product":"openshift_application_runtimes","vendor":"redhat"},{"product":"smallrye_health","vendor":"redhat"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"It was found that the smallrye health metrics UI component did not properly sanitize some user inputs. An attacker could use this flaw to conduct cross-site scripting attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SmallRye Health UI Cross-site Scripting vulnerability","id":"CVE-2021-3914","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Unrestricted Upload of File with Dangerous Type in bookstackapp/bookstack","id":"CVE-2021-3915"},"packages":[{"ecosystem":"Maven","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"io.smallrye:smallrye-health-ui","purl":null,"source":"GHSA-pvc3-wvxr-7cmf"},{"ecosystem":"Maven","fixed":["3.1.2"],"introduced":["0"],"last_affected":[],"package":"io.smallrye:smallrye-health-ui","purl":"pkg:maven/io.smallrye/smallrye-health-ui","source":"GHSA-pvc3-wvxr-7cmf"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2021-3913"},"products":["smallrye-health"],"published":"2022-08-25","related":[{"cvss_score":7.5,"headline":"Undertow client not checking server identity presented by server certificate in https connections","id":"CVE-2022-4492","kev_date_added":null,"published":"2023-02-23"},{"cvss_score":6.5,"headline":"quarkus-core vulnerable to client driven TLS cipher downgrading","id":"CVE-2023-2974","kev_date_added":null,"published":"2023-07-04"},{"cvss_score":6.5,"headline":"Keycloak Untrusted Certificate Validation vulnerability","id":"CVE-2023-1664","kev_date_added":null,"published":"2023-05-26"},{"cvss_score":5.3,"headline":"Quarkus: potential invalid reuse of context when @cacheresult on a uni is used","id":"CVE-2023-6393","kev_date_added":null,"published":"2023-12-06"},{"cvss_score":4.8,"headline":"Cross-site Scripting in Wildfly","id":"CVE-2021-3536","kev_date_added":null,"published":"2021-05-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An attacker can execute arbitrary scripts in the SmallRye Health Metrics UI due to insufficient input sanitization, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2021-3914/"}