# CVE-2021-3914: SmallRye Health UI Cross-site Scripting vulnerability

> An attacker can execute arbitrary scripts in the SmallRye Health Metrics UI due to insufficient input sanitization, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-pvc3-wvxr-7cmf

## What is CVE-2021-3914?

CVE-2021-3914 is a medium-severity cross-site scripting vulnerability in smallrye-health, published on 25 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

It was found that the smallrye health metrics UI component did not properly sanitize some user inputs. An attacker could use this flaw to conduct cross-site scripting attacks.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-3914?

2 open source packages ship an affected version, including io.smallrye:smallrye-health-ui. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.smallrye:smallrye-health-ui` | Maven | All versions | 3.1.2 |
| `io.smallrye:smallrye-health-ui` | Maven | All versions | 3.1.2 |

Products: Redhat Build of Quarkus, Redhat Openshift Application Runtimes, Redhat Smallrye Health.

## How do I fix CVE-2021-3914?

Upgrade io.smallrye:smallrye-health-ui to 3.1.2 or later.

## Is CVE-2021-3914 being exploited?

There is no known exploitation of CVE-2021-3914 in the wild and no public exploit code.

## Other vulnerabilities in smallrye-health

- [CVE-2022-4492](https://insights.sbomify.com/CVE-2022-4492/): Undertow client not checking server identity presented by server certificate in https connections (high 7.5)
- [CVE-2023-2974](https://insights.sbomify.com/CVE-2023-2974/): quarkus-core vulnerable to client driven TLS cipher downgrading (medium 6.5)
- [CVE-2023-1664](https://insights.sbomify.com/CVE-2023-1664/): Keycloak Untrusted Certificate Validation vulnerability (medium 6.5)
- [CVE-2023-6393](https://insights.sbomify.com/CVE-2023-6393/): Quarkus: potential invalid reuse of context when @cacheresult on a uni is used (medium 5.3)
- [CVE-2021-3536](https://insights.sbomify.com/CVE-2021-3536/): Cross-site Scripting in Wildfly (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3914 and fix it if it is affected.

What it is: CVE-2021-3914 is a medium-severity cross-site scripting vulnerability in smallrye-health, published on 25 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-3914 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.smallrye:smallrye-health-ui (Maven): affected all versions; fixed in 3.1.2
- io.smallrye:smallrye-health-ui (Maven): affected all versions; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3914/ (Markdown: https://insights.sbomify.com/CVE-2021-3914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3914
- OSV: https://osv.dev/vulnerability/CVE-2021-3914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3914/
Summaries are generated and may contain mistakes; the official description above is the record.
