# CVE-2021-39151: XStream is vulnerable to an Arbitrary Code Execution attack

> Remote attackers can execute arbitrary code by manipulating serialized input streams in XStream, unless a strict type whitelist is configured.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2021
- **Updated:** 7 Oct 2026
- **Also known as:** DEBIAN-CVE-2021-39151, GHSA-hph2-m3g5-xxv4, UBUNTU-CVE-2021-39151

## What is CVE-2021-39151?

CVE-2021-39151 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 23 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XStream is a simple library to serialize objects to XML and back again. In affected versions this vulnerability may allow a remote attacker to load and execute arbitrary code from a remote host only by manipulating the processed input stream. No user is affected, who followed the recommendation to setup XStream's security framework with a whitelist limited to the minimal required types. XStream 1.4.18 uses no longer a blacklist by default, since it cannot be secured for general purpose.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2021-39151?

2 open source packages ship an affected version, including com.thoughtworks.xstream:xstream. It affects 15 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.18 |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.18 |

Products: Debian Debian Linux, Fedoraproject Fedora, Netapp Snapmanager, Oracle Business Activity Monitoring, Oracle Commerce Guided Search, Oracle Communications Billing and Revenue Management Elastic Charging Engine, Oracle Communications Cloud Native Core Automated Test Suite, Oracle Communications Cloud Native Core Binding Support Function, Oracle Communications Cloud Native Core Policy, Oracle Communications Unified Inventory Management, Oracle Retail Xstore Point of Service, Oracle Utilities Framework, Oracle Utilities Testing Accelerator, Oracle Webcenter Portal, Xstream Xstream.

## How do I fix CVE-2021-39151?

Upgrade com.thoughtworks.xstream:xstream to 1.4.18 or later.

## Is CVE-2021-39151 being exploited?

There is no known exploitation of CVE-2021-39151 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39151 and fix it if it is affected.

What it is: CVE-2021-39151 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 23 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39151 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.18
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39151/ (Markdown: https://insights.sbomify.com/CVE-2021-39151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39151
- OSV: https://osv.dev/vulnerability/CVE-2021-39151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39151/
Summaries are generated and may contain mistakes; the official description above is the record.
