# CVE-2021-39156: Fragments in Path May Lead to Authorization Policy Bypass

> Attackers can bypass Istio URI path authorization policies by including fragments in HTTP requests, requiring patches to secure microservice traffic.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hqxw-mm44-gc4r, MINI-q55p-qmgc-gwg5, MINI-rh7w-f67j-vqv4

## What is CVE-2021-39156?

CVE-2021-39156 is a high-severity authentication bypass vulnerability in istio, published on 24 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Istio is an open source platform for providing a uniform way to integrate microservices, manage traffic flow across microservices, enforce policies and aggregate telemetry data. Istio 1.11.0, 1.10.3 and below, and 1.9.7 and below contain a remotely exploitable vulnerability where an HTTP request with `#fragment` in the path may bypass Istio’s URI path based authorization policies. Patches are available in Istio 1.11.1, Istio 1.10.4 and Istio 1.9.8. As a work around a Lua filter may be written to normalize the path.

Weakness: CWE-706 (Use of Incorrectly-Resolved Name or Reference), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2021-39156?

6 open source packages ship an affected version, including istio.io/istio. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `istio.io/istio` | Go | All versions | 1.9.8 |
| `istio.io/istio` | Go | All versions | 1.9.8 |
| `istio.io/istio` | Go | From 1.10.0 | 1.10.4 |
| `istio.io/istio` | Go | From 1.10.0 | 1.10.4 |
| `istio.io/istio` | Go | From 1.11.0 | 1.11.1 |
| `istio.io/istio` | Go | From 1.11.0 | 1.11.1 |

Products: Istio Istio.

## How do I fix CVE-2021-39156?

Upgrade istio.io/istio to a fixed version for your release line: 1.9.8, 1.10.4 or 1.11.1.

## Is CVE-2021-39156 being exploited?

There is no known exploitation of CVE-2021-39156 in the wild and no public exploit code.

Public exploit code:

- https://github.com/mostafaanouarghorab/MicroserviceCVE-2021-39156 (github_poc): https://github.com/mostafaanouarghorab/MicroserviceCVE-2021-39156

## Other vulnerabilities in istio

- [CVE-2021-31921](https://insights.sbomify.com/CVE-2021-31921/): Missing authorization in n/a (critical 9.8)
- [CVE-2021-34824](https://insights.sbomify.com/CVE-2021-34824/): Information disclosure in n/a (high 8.8)
- [CVE-2026-31837](https://insights.sbomify.com/CVE-2026-31837/): Istio JWKS resolver to prevent private key material from being exposed when JWKS fetch fails. (high 8.7)
- [CVE-2021-39155](https://insights.sbomify.com/CVE-2021-39155/): Authorization Policy Bypass Due to Case Insensitive Host Comparison (high 8.3)
- [CVE-2022-39388](https://insights.sbomify.com/CVE-2022-39388/): Istio may allow identity impersonation if user has localhost access (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39156 and fix it if it is affected.

What it is: CVE-2021-39156 is a high-severity authentication bypass vulnerability in istio, published on 24 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-39156 in the wild and no public exploit code.

Affected packages and fixed versions:
- istio.io/istio (Go): affected all versions; fixed in 1.9.8
- istio.io/istio (Go): affected all versions; fixed in 1.9.8
- istio.io/istio (Go): affected from 1.10.0; fixed in 1.10.4
- istio.io/istio (Go): affected from 1.10.0; fixed in 1.10.4
- istio.io/istio (Go): affected from 1.11.0; fixed in 1.11.1
- istio.io/istio (Go): affected from 1.11.0; fixed in 1.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39156/ (Markdown: https://insights.sbomify.com/CVE-2021-39156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39156
- OSV: https://osv.dev/vulnerability/CVE-2021-39156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39156/
Summaries are generated and may contain mistakes; the official description above is the record.
