CVE-2021-39160 Code injection in nbgitpuller

Critical 9.6 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2021-39160?

CVE-2021-39160 is a critical vulnerability in jupyterhub nbgitpuller, published on 25 Aug 2021.

Official description

nbgitpuller is a Jupyter server extension to sync a git repository one-way to a local path. Due to unsanitized input, visiting maliciously crafted links could result in arbitrary code execution in the user environment. This has been resolved in version 0.10.2 and all users are advised to upgrade. No work around exist for users who can not upgrade.

Weakness: CWE-78, CWE-94

Which versions are affected by CVE-2021-39160?

3 open source packages ship an affected version, including nbgitpuller. It affects 1 product.

PackageAffectedFixed in
nbgitpuller PyPIFrom 0.9.00.10.2
nbgitpuller PyPIFrom 0.9.00.10.2
nbgitpuller PyPIFrom 0.9.00.10.2

Products include Jupyterhub Nbgitpuller.

How do I fix CVE-2021-39160?

Upgrade nbgitpuller to 0.10.2 or later.

Is CVE-2021-39160 being exploited?

There is no known exploitation of CVE-2021-39160 in the wild and no public exploit code.

Sources

Also known as GHSA-mq5p-2mcr-m52j, PYSEC-2021-315.

Is CVE-2021-39160 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free