# CVE-2021-39160: Code injection in nbgitpuller


- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mq5p-2mcr-m52j, PYSEC-2021-315

## What is CVE-2021-39160?

CVE-2021-39160 is a critical vulnerability in jupyterhub nbgitpuller, published on 25 Aug 2021. 

### Official description

nbgitpuller is a Jupyter server extension to sync a git repository one-way to a local path. Due to unsanitized input, visiting maliciously crafted links could result in arbitrary code execution in the user environment. This has been resolved in version 0.10.2 and all users are advised to upgrade. No work around exist for users who can not upgrade.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-39160?

3 open source packages ship an affected version, including nbgitpuller. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nbgitpuller` | PyPI | From 0.9.0 | 0.10.2 |
| `nbgitpuller` | PyPI | From 0.9.0 | 0.10.2 |
| `nbgitpuller` | PyPI | From 0.9.0 | 0.10.2 |

Products: Jupyterhub Nbgitpuller.

## How do I fix CVE-2021-39160?

Upgrade nbgitpuller to 0.10.2 or later.

## Is CVE-2021-39160 being exploited?

There is no known exploitation of CVE-2021-39160 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39160 and fix it if it is affected.

What it is: CVE-2021-39160 is a critical vulnerability in jupyterhub nbgitpuller, published on 25 Aug 2021. 
Exploitation: There is no known exploitation of CVE-2021-39160 in the wild and no public exploit code.

Affected packages and fixed versions:
- nbgitpuller (PyPI): affected from 0.9.0; fixed in 0.10.2
- nbgitpuller (PyPI): affected from 0.9.0; fixed in 0.10.2
- nbgitpuller (PyPI): affected from 0.9.0; fixed in 0.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39160/ (Markdown: https://insights.sbomify.com/CVE-2021-39160/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39160
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39160
- OSV: https://osv.dev/vulnerability/CVE-2021-39160

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39160/
Summaries are generated and may contain mistakes; the official description above is the record.
