# CVE-2021-39163: Adding a private/unlisted room to a community exposes room metadata in an unauthorised manner.

> Unauthorised users can access private room metadata if group creation is enabled, requiring an upgrade to Matrix Synapse.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jj53-8fmw-f2w2, PYSEC-2021-424, UBUNTU-CVE-2021-39163

## What is CVE-2021-39163?

CVE-2021-39163 is a low-severity vulnerability in Fedoraproject Fedora, published on 31 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Matrix is an ecosystem for open federated Instant Messaging and Voice over IP. In versions 1.41.0 and prior, unauthorised users can access the name, avatar, topic and number of members of a room if they know the ID of the room. This vulnerability is limited to homeservers where the vulnerable homeserver is in the room and untrusted users are permitted to create groups (communities). By default, only homeserver administrators can create groups. However, homeserver administrators can already access this information in the database or using the admin API. As a result, only homeservers where the configuration setting `enable_group_creation` has been set to `true` are impacted. Server administrators should upgrade to 1.41.1 or higher to patch the vulnerability. There are two potential workarounds. Server administrators can set `enable_group_creation` to `false` in their homeserver configuration (this is the default value) to prevent creation of groups by non-administrators. Administrators that are using a reverse proxy could, with partial loss of group functionality, block the endpoints `/_matrix/client/r0/groups/{group_id}/rooms` and `/_matrix/client/unstable/groups/{group_id}/rooms`.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-39163?

3 open source packages ship an affected version, including matrix-synapse. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.41.1 |
| `matrix-synapse` | PyPI | All versions | 1.41.1 |
| `matrix-synapse` | PyPI | All versions | 1.41.1 |

Products: Fedoraproject Fedora, Matrix Synapse.

## How do I fix CVE-2021-39163?

Upgrade matrix-synapse to 1.41.1 or later.

## Is CVE-2021-39163 being exploited?

There is no known exploitation of CVE-2021-39163 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39163 and fix it if it is affected.

What it is: CVE-2021-39163 is a low-severity vulnerability in Fedoraproject Fedora, published on 31 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39163 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.41.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.41.1
- matrix-synapse (PyPI): affected all versions; fixed in 1.41.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39163/ (Markdown: https://insights.sbomify.com/CVE-2021-39163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39163
- OSV: https://osv.dev/vulnerability/CVE-2021-39163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39163/
Summaries are generated and may contain mistakes; the official description above is the record.
