{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-39166 in the wild and no public exploit code.","fix":"Upgrade pimcore/pimcore to 10.1.2 or later.","what":"CVE-2021-39166 is a high-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 1 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-39166 and fix it if it is affected.\n\nWhat it is: CVE-2021-39166 is a high-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 1 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-39166 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pimcore/pimcore (Packagist): affected all versions; fixed in 10.1.2\n- pimcore/pimcore (Packagist): affected all versions; fixed in 10.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-39166/ (Markdown: https://insights.sbomify.com/CVE-2021-39166/index.md)","id":"CVE-2021-39166","markdown":"https://insights.sbomify.com/CVE-2021-39166/index.md","name":"CVE-2021-39166","record":{"aliases":["GHSA-w6j8-jc36-x5q9"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore DXP","requires_auth":"low_privilege","summary":"Authenticated users can execute arbitrary scripts via unescaped text values in the version preview feature of Pimcore.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"pimcore","vendor":"pimcore"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Pimcore is an open source data \u0026 experience management platform. Prior to version 10.1.2, text-values were not properly escaped before printed in the version preview. This allowed XSS by authenticated users with access to the resources. This issue is patched in Pimcore version 10.1.2.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Text-Values in Object Version Preview","id":"CVE-2021-39166","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"pimcore:pimcore","products":["pimcore:pimcore"],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"TimelockController vulnerability in OpenZeppelin Contracts","id":"CVE-2021-39167"},"packages":[{"ecosystem":"Packagist","fixed":["10.1.2"],"introduced":["0"],"last_affected":[],"package":"pimcore/pimcore","purl":null,"source":"GHSA-w6j8-jc36-x5q9"},{"ecosystem":"Packagist","fixed":["10.1.2"],"introduced":["0"],"last_affected":[],"package":"pimcore/pimcore","purl":"pkg:composer/pimcore/pimcore","source":"GHSA-w6j8-jc36-x5q9"}],"prev":{"headline":"Unauthenticated SQL Injection","id":"CVE-2021-39165"},"products":["pimcore"],"published":"2021-09-01","related":[{"cvss_score":9.8,"headline":"RCE vulnerability in Pimcore/Mail \u0026 Dynamic Text Layout","id":"CVE-2022-39365","kev_date_added":null,"published":"2022-10-27"},{"cvss_score":9.8,"headline":"Pimcore Access Control Issues","id":"CVE-2019-18981","kev_date_added":null,"published":"2019-11-15"},{"cvss_score":9.8,"headline":"Pimcore 2FA Vulnerable to Brute Forcing","id":"CVE-2019-18985","kev_date_added":null,"published":"2019-11-15"},{"cvss_score":8.8,"headline":"Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848","id":"CVE-2026-23492","kev_date_added":null,"published":"2026-01-14"},{"cvss_score":8.8,"headline":"SQL Injection in Admin Grid Filter API in Pimcore","id":"CVE-2023-47637","kev_date_added":null,"published":"2023-11-15"},{"cvss_score":8.8,"headline":"Pimcore SQL Injection Vulnerability in Admin Search Find API","id":"CVE-2023-30848","kev_date_added":null,"published":"2023-04-27"},{"cvss_score":8.8,"headline":"Pimcore vulnerable to SQL Injection in Translation Export API","id":"CVE-2023-30849","kev_date_added":null,"published":"2023-04-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["pimcore"]},"summary":"Authenticated users can execute arbitrary scripts via unescaped text values in the version preview feature of Pimcore.","url":"https://insights.sbomify.com/CVE-2021-39166/"}