# CVE-2021-39170: Improper Encoding or Escaping of Output in Asset Metadata Component

> Authenticated users can inject XSS payloads into asset metadata, potentially executing malicious scripts in other users' browsers.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2v88-qq7x-xq5f

## What is CVE-2021-39170?

CVE-2021-39170 is a high-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 1 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Pimcore is an open source data & experience management platform. Prior to version 10.1.2, an authenticated user could add XSS code as a value of custom metadata on assets. There is a patch for this issue in Pimcore version 10.1.2. As a workaround, users may apply the patch manually.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2021-39170?

2 open source packages ship an affected version, including pimcore/pimcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/pimcore` | Packagist | All versions | 10.1.2 |
| `pimcore/pimcore` | Packagist | All versions | 10.1.2 |

Products: Pimcore Pimcore.

## How do I fix CVE-2021-39170?

Upgrade pimcore/pimcore to 10.1.2 or later.

## Is CVE-2021-39170 being exploited?

There is no known exploitation of CVE-2021-39170 in the wild and no public exploit code.

## Other vulnerabilities in Pimcore Pimcore

- [CVE-2022-39365](https://insights.sbomify.com/CVE-2022-39365/): RCE vulnerability in Pimcore/Mail & Dynamic Text Layout (critical 9.8)
- [CVE-2019-18981](https://insights.sbomify.com/CVE-2019-18981/): Pimcore Access Control Issues (critical 9.8)
- [CVE-2019-18985](https://insights.sbomify.com/CVE-2019-18985/): Pimcore 2FA Vulnerable to Brute Forcing (critical 9.8)
- [CVE-2026-23492](https://insights.sbomify.com/CVE-2026-23492/): Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 (high 8.8)
- [CVE-2023-47637](https://insights.sbomify.com/CVE-2023-47637/): SQL Injection in Admin Grid Filter API in Pimcore (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39170 and fix it if it is affected.

What it is: CVE-2021-39170 is a high-severity cross-site scripting vulnerability in Pimcore Pimcore, published on 1 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-39170 in the wild and no public exploit code.

Affected packages and fixed versions:
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.1.2
- pimcore/pimcore (Packagist): affected all versions; fixed in 10.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39170/ (Markdown: https://insights.sbomify.com/CVE-2021-39170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39170
- OSV: https://osv.dev/vulnerability/CVE-2021-39170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39170/
Summaries are generated and may contain mistakes; the official description above is the record.
