{"answers":{"affected":"2 open source packages ship an affected version, including passport-saml. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-39171 in the wild and no public exploit code.","fix":"Upgrade passport-saml to 3.1.0 or later.","what":"CVE-2021-39171 is a medium-severity denial of service vulnerability in node-saml passport-saml, published on 27 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-39171 and fix it if it is affected.\n\nWhat it is: CVE-2021-39171 is a medium-severity denial of service vulnerability in node-saml passport-saml, published on 27 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-39171 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passport-saml (npm): affected all versions; fixed in 3.1.0\n- passport-saml (npm): affected all versions; fixed in 3.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-39171/ (Markdown: https://insights.sbomify.com/CVE-2021-39171/index.md)","id":"CVE-2021-39171","markdown":"https://insights.sbomify.com/CVE-2021-39171/index.md","name":"CVE-2021-39171","record":{"aliases":["GHSA-5379-r78w-42h2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js SAML library","requires_auth":"none","summary":"Attackers can cause denial of service by sending SAML payloads with unlimited transforms, consuming excessive system resources.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"passport-saml","vendor":"passport-saml_project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. Prior to version 3.1.0, a malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack. This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unlimited transforms allowed for signed nodes","id":"CVE-2021-39171","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"New line injection during configuration edition","id":"CVE-2021-39172"},"packages":[{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"passport-saml","purl":null,"source":"GHSA-5379-r78w-42h2"},{"ecosystem":"npm","fixed":["3.1.0"],"introduced":["0"],"last_affected":[],"package":"passport-saml","purl":"pkg:npm/passport-saml","source":"GHSA-5379-r78w-42h2"}],"prev":{"headline":"Improper Encoding or Escaping of Output in Asset Metadata Component","id":"CVE-2021-39170"},"products":["passport-saml"],"published":"2021-08-27","related":[{"cvss_score":7.4,"headline":"Signature bypass via multiple root elements in Passport-SAML","id":"CVE-2022-39299","kev_date_added":null,"published":"2022-10-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["node-saml"]},"summary":"Attackers can cause denial of service by sending SAML payloads with unlimited transforms, consuming excessive system resources.","url":"https://insights.sbomify.com/CVE-2021-39171/"}