# CVE-2021-39171: Unlimited transforms allowed for signed nodes

> Attackers can cause denial of service by sending SAML payloads with unlimited transforms, consuming excessive system resources.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5379-r78w-42h2

## What is CVE-2021-39171?

CVE-2021-39171 is a medium-severity denial of service vulnerability in node-saml passport-saml, published on 27 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Passport-SAML is a SAML 2.0 authentication provider for Passport, the Node.js authentication library. Prior to version 3.1.0, a malicious SAML payload can require transforms that consume significant system resources to process, thereby resulting in reduced or denied service. This would be an effective way to perform a denial-of-service attack. This has been resolved in version 3.1.0. The resolution is to limit the number of allowable transforms to 2.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-39171?

2 open source packages ship an affected version, including passport-saml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passport-saml` | npm | All versions | 3.1.0 |
| `passport-saml` | npm | All versions | 3.1.0 |

Products: Passport-Saml Project Passport-Saml.

## How do I fix CVE-2021-39171?

Upgrade passport-saml to 3.1.0 or later.

## Is CVE-2021-39171 being exploited?

There is no known exploitation of CVE-2021-39171 in the wild and no public exploit code.

## Other vulnerabilities in node-saml passport-saml

- [CVE-2022-39299](https://insights.sbomify.com/CVE-2022-39299/): Signature bypass via multiple root elements in Passport-SAML (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39171 and fix it if it is affected.

What it is: CVE-2021-39171 is a medium-severity denial of service vulnerability in node-saml passport-saml, published on 27 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39171 in the wild and no public exploit code.

Affected packages and fixed versions:
- passport-saml (npm): affected all versions; fixed in 3.1.0
- passport-saml (npm): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39171/ (Markdown: https://insights.sbomify.com/CVE-2021-39171/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39171
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39171
- OSV: https://osv.dev/vulnerability/CVE-2021-39171

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39171/
Summaries are generated and may contain mistakes; the official description above is the record.
