{"answers":{"affected":"2 open source packages ship an affected version, including cachethq/cachet. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-39173 in the wild and no public exploit code.","fix":"Upgrade cachethq/cachet to 2.5.1 or later.","what":"CVE-2021-39173 is a high-severity vulnerability in fiveai Cachet, published on 27 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-39173 and fix it if it is affected.\n\nWhat it is: CVE-2021-39173 is a high-severity vulnerability in fiveai Cachet, published on 27 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-39173 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cachethq/cachet (Packagist): affected all versions; fixed in 2.5.1\n- cachethq/cachet (Packagist): affected all versions; fixed in 2.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-39173/ (Markdown: https://insights.sbomify.com/CVE-2021-39173/index.md)","id":"CVE-2021-39173","markdown":"https://insights.sbomify.com/CVE-2021-39173/index.md","name":"CVE-2021-39173","record":{"aliases":["GHSA-r67m-m8c7-jp83"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Cachet status page","requires_auth":"low_privilege","summary":"Authenticated users can bypass installation checks to reinstall the system, leading to arbitrary code execution on the server.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"catchet","vendor":"catchethq"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-704","name":"Incorrect Type Conversion or Cast"}],"description":"Cachet is an open source status page system. Prior to version 2.5.1 authenticated users, regardless of their privileges (User or Admin), can trick Cachet and install the instance again, leading to arbitrary code execution on the server. This issue was addressed in version 2.5.1 by improving the middleware `ReadyForUse`, which now performs a stricter validation of the instance name. As a workaround, only allow trusted source IP addresses to access to the administration dashboard.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Forced reinstall","id":"CVE-2021-39173","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"security_feature_bypass","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Configuration leak","id":"CVE-2021-39174"},"packages":[{"ecosystem":"Packagist","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"cachethq/cachet","purl":null,"source":"GHSA-r67m-m8c7-jp83"},{"ecosystem":"Packagist","fixed":["2.5.1"],"introduced":["0"],"last_affected":[],"package":"cachethq/cachet","purl":"pkg:composer/cachethq/cachet","source":"GHSA-r67m-m8c7-jp83"}],"prev":{"headline":"New line injection during configuration edition","id":"CVE-2021-39172"},"products":["Cachet"],"published":"2021-08-27","related":[{"cvss_score":8.8,"headline":"New line injection during configuration edition","id":"CVE-2021-39172","kev_date_added":null,"published":"2021-08-27"},{"cvss_score":8.8,"headline":"Configuration leak","id":"CVE-2021-39174","kev_date_added":null,"published":"2021-08-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["fiveai"]},"summary":"Authenticated users can bypass installation checks to reinstall the system, leading to arbitrary code execution on the server.","url":"https://insights.sbomify.com/CVE-2021-39173/"}