# CVE-2021-39173: Forced reinstall

> Authenticated users can bypass installation checks to reinstall the system, leading to arbitrary code execution on the server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-r67m-m8c7-jp83

## What is CVE-2021-39173?

CVE-2021-39173 is a high-severity vulnerability in fiveai Cachet, published on 27 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cachet is an open source status page system. Prior to version 2.5.1 authenticated users, regardless of their privileges (User or Admin), can trick Cachet and install the instance again, leading to arbitrary code execution on the server. This issue was addressed in version 2.5.1 by improving the middleware `ReadyForUse`, which now performs a stricter validation of the instance name. As a workaround, only allow trusted source IP addresses to access to the administration dashboard.

Weakness: CWE-704 (Incorrect Type Conversion or Cast)

## Which versions are affected by CVE-2021-39173?

2 open source packages ship an affected version, including cachethq/cachet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cachethq/cachet` | Packagist | All versions | 2.5.1 |
| `cachethq/cachet` | Packagist | All versions | 2.5.1 |

Products: Catchethq Catchet.

## How do I fix CVE-2021-39173?

Upgrade cachethq/cachet to 2.5.1 or later.

## Is CVE-2021-39173 being exploited?

There is no known exploitation of CVE-2021-39173 in the wild and no public exploit code.

## Other vulnerabilities in fiveai Cachet

- [CVE-2021-39172](https://insights.sbomify.com/CVE-2021-39172/): New line injection during configuration edition (high 8.8)
- [CVE-2021-39174](https://insights.sbomify.com/CVE-2021-39174/): Configuration leak (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39173 and fix it if it is affected.

What it is: CVE-2021-39173 is a high-severity vulnerability in fiveai Cachet, published on 27 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39173 in the wild and no public exploit code.

Affected packages and fixed versions:
- cachethq/cachet (Packagist): affected all versions; fixed in 2.5.1
- cachethq/cachet (Packagist): affected all versions; fixed in 2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39173/ (Markdown: https://insights.sbomify.com/CVE-2021-39173/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39173
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39173
- OSV: https://osv.dev/vulnerability/CVE-2021-39173

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39173/
Summaries are generated and may contain mistakes; the official description above is the record.
