# CVE-2021-39177: User impersonation due to incorrect handling of the login JWT

> Attackers can impersonate any user by forging JWT tokens in login packets, allowing unauthorized access to the Minecraft bridge server.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-h77f-xxx7-4858

## What is CVE-2021-39177?

CVE-2021-39177 is a high-severity authentication bypass vulnerability in GeyserMC Geyser, published on 30 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Geyser is a bridge between Minecraft: Bedrock Edition and Minecraft: Java Edition. Versions of Geyser prior to 1.4.2-SNAPSHOT allow anyone that can connect to the server to forge a LoginPacket with manipulated JWT token allowing impersonation as any user. Version 1.4.2-SNAPSHOT contains a patch for the issue. There are no known workarounds aside from upgrading.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-39177?

2 open source packages ship an affected version, including org.geysermc:connector. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.geysermc:connector` | Maven | All versions | 1.4.2-SNAPSHOT |
| `org.geysermc:connector` | Maven | All versions | 1.4.2-SNAPSHOT |

Products: Geysermc Geyser.

## How do I fix CVE-2021-39177?

Upgrade org.geysermc:connector to 1.4.2-SNAPSHOT or later.

## Is CVE-2021-39177 being exploited?

There is no known exploitation of CVE-2021-39177 in the wild and no public exploit code.

## Other vulnerabilities in GeyserMC Geyser

- [CVE-2026-42188](https://insights.sbomify.com/CVE-2026-42188/): Geyser: Server-Side Request Forgery (SSRF) via Player Head Texture URL (low 2.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39177 and fix it if it is affected.

What it is: CVE-2021-39177 is a high-severity authentication bypass vulnerability in GeyserMC Geyser, published on 30 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39177 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.geysermc:connector (Maven): affected all versions; fixed in 1.4.2-SNAPSHOT
- org.geysermc:connector (Maven): affected all versions; fixed in 1.4.2-SNAPSHOT

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39177/ (Markdown: https://insights.sbomify.com/CVE-2021-39177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39177
- OSV: https://osv.dev/vulnerability/CVE-2021-39177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39177/
Summaries are generated and may contain mistakes; the official description above is the record.
