# CVE-2021-39180: Path Traversal in Archive Handling Leading to Code Execution

> Authenticated attackers can exploit path traversal in ZIP handling to overwrite files and potentially execute code on the server.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-x95v-2pgj-9x8j

## What is CVE-2021-39180?

CVE-2021-39180 is a high-severity path traversal vulnerability in OpenOLAT, published on 31 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenOLAT is a web-based learning management system (LMS). A path traversal vulnerability exists in versions prior to 15.3.18, 15.5.3, and 16.0.0. Using a specially prepared ZIP file, it is possible to overwrite any file that is writable by the application server user (e.g. the tomcat user). Depending on the configuration this can be limited to files of the OpenOlat user data directory, however, if not properly set up, the attack could also be used to overwrite application server config files, java code or even operating system files. The attack could be used to corrupt or modify any OpenOlat file such as course structures, config files or temporary test data. Those attack would require in-depth knowledge of the installation and thus more theoretical. If the app server configuration allows the execution of jsp files and the path to the context is known, it is also possible to execute java code. If the app server runs with the same user that is used to deploy the OpenOlat code or has write permissions on the OpenOlat code files and the path to the context is know, code injection is possible. The attack requires an OpenOlat user account to upload a ZIP file and trigger the unzip method. It can not be exploited by unregistered users. The problem is fixed in versions 15.3.18, 15.5.3 and 16.0.0. There are no known workarounds aside from upgrading.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-39180?

It affects 1 product.


Products: Frentix Openolat.

## How do I fix CVE-2021-39180?

No fix has been published for CVE-2021-39180 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-39180 being exploited?

There is no known exploitation of CVE-2021-39180 in the wild and no public exploit code.

## Other vulnerabilities in OpenOLAT

- [CVE-2026-31946](https://insights.sbomify.com/CVE-2026-31946/): OpenOLAT: Authentication bypass via forged JWT in OIDC implicit flow (critical 9.8)
- [CVE-2026-28228](https://insights.sbomify.com/CVE-2026-28228/): OpenOLAT: Server-Side Template Injection (SSTI) in Velocity templates allows Remote Code Execution (high 8.8)
- [CVE-2021-39181](https://insights.sbomify.com/CVE-2021-39181/): Unsafe Deserialization of User Data Using XStream (high 8.8)
- [CVE-2021-41242](https://insights.sbomify.com/CVE-2021-41242/): Path Traversal in some REST methods leading to file upload to arbitrary places (high 8.1)
- [CVE-2021-41152](https://insights.sbomify.com/CVE-2021-41152/): Path Traversal in Folder Component Leading to Local File Inclusion (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39180 and fix it if it is affected.

What it is: CVE-2021-39180 is a high-severity path traversal vulnerability in OpenOLAT, published on 31 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39180 in the wild and no public exploit code.

Affected product: OpenOLAT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39180/ (Markdown: https://insights.sbomify.com/CVE-2021-39180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39180
- OSV: https://osv.dev/vulnerability/CVE-2021-39180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39180/
Summaries are generated and may contain mistakes; the official description above is the record.
