# CVE-2021-39184: Sandboxed renderers can obtain thumbnails of arbitrary files through the nativeImage API

> A sandboxed renderer in Electron can access thumbnails of arbitrary local files, potentially exposing sensitive textual data to attackers.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mpjm-v997-c4h4

## What is CVE-2021-39184?

CVE-2021-39184 is a medium-severity vulnerability in Electronjs Electron, published on 12 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. A vulnerability in versions prior to 11.5.0, 12.1.0, and 13.3.0 allows a sandboxed renderer to request a "thumbnail" image of an arbitrary file on the user's system. The thumbnail can potentially include significant parts of the original file, including textual data in many cases. Versions 15.0.0-alpha.10, 14.0.0, 13.3.0, 12.1.0, and 11.5.0 all contain a fix for the vulnerability. Two workarounds aside from upgrading are available. One may make the vulnerability significantly more difficult for an attacker to exploit by enabling `contextIsolation` in one's app. One may also disable the functionality of the `createThumbnailFromPath` API if one does not need it.

Weakness: CWE-862 (Missing Authorization), CWE-668 (Exposure of Resource to Wrong Sphere)

## Which versions are affected by CVE-2021-39184?

6 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 11.5.0 |
| `electron` | npm | All versions | 11.5.0 |
| `electron` | npm | From 12.0.0 | 12.1.0 |
| `electron` | npm | From 12.0.0 | 12.1.0 |
| `electron` | npm | From 13.0.0 | 13.3.0 |
| `electron` | npm | From 13.0.0 | 13.3.0 |

Products: Electronjs Electron.

## How do I fix CVE-2021-39184?

Upgrade electron to a fixed version for your release line: 11.5.0, 12.1.0 or 13.3.0.

## Is CVE-2021-39184 being exploited?

There is no known exploitation of CVE-2021-39184 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39184 and fix it if it is affected.

What it is: CVE-2021-39184 is a medium-severity vulnerability in Electronjs Electron, published on 12 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39184 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 11.5.0
- electron (npm): affected all versions; fixed in 11.5.0
- electron (npm): affected from 12.0.0; fixed in 12.1.0
- electron (npm): affected from 12.0.0; fixed in 12.1.0
- electron (npm): affected from 13.0.0; fixed in 13.3.0
- electron (npm): affected from 13.0.0; fixed in 13.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39184/ (Markdown: https://insights.sbomify.com/CVE-2021-39184/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39184
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39184
- OSV: https://osv.dev/vulnerability/CVE-2021-39184

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39184/
Summaries are generated and may contain mistakes; the official description above is the record.
