{"answers":{"affected":"3 open source packages ship an affected version, including parse-server and parse. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-39187 in the wild and no public exploit code.","fix":"Upgrade parse-server to 4.10.3 or later.","what":"CVE-2021-39187 is a high-severity denial of service vulnerability in Parseplatform Parse-Server, published on 2 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-39187 and fix it if it is affected.\n\nWhat it is: CVE-2021-39187 is a high-severity denial of service vulnerability in Parseplatform Parse-Server, published on 2 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-39187 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected all versions; fixed in 4.10.3\n- parse-server (npm): affected all versions; fixed in 4.10.3\n- parse (Bitnami): affected all versions; fixed in 4.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-39187/ (Markdown: https://insights.sbomify.com/CVE-2021-39187/index.md)","id":"CVE-2021-39187","markdown":"https://insights.sbomify.com/CVE-2021-39187/index.md","name":"CVE-2021-39187","record":{"aliases":["BIT-parse-2021-39187","GHSA-xqp8-w826-hh6x"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Parse Server backend","requires_auth":"none","summary":"An attacker can crash the Parse Server by sending a query with an invalid explain option, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"parse-server","vendor":"parseplatform"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-755","name":"Improper Handling of Exceptional Conditions"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to version 4.10.3, Parse Server crashes when if a query request contains an invalid value for the `explain` option. This is due to a bug in the MongoDB Node.js driver which throws an exception that Parse Server cannot catch. There is a patch for this issue in version 4.10.3. No workarounds aside from upgrading are known to exist.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Crash server with query parameter","id":"CVE-2021-39187","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"parseplatform:parse-server","products":["parseplatform:parse-server"],"type":"denial_of_service","year":"2021"},"n_packages":3,"n_references":4,"next":{"headline":"Observable Response Discrepancy in Lost Password Service","id":"CVE-2021-39189"},"packages":[{"ecosystem":"Bitnami","fixed":["4.10.3"],"introduced":["0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2021-39187"},{"ecosystem":"npm","fixed":["4.10.3"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-xqp8-w826-hh6x"},{"ecosystem":"npm","fixed":["4.10.3"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-xqp8-w826-hh6x"}],"prev":{"headline":"Improper Input Validation in GlobalNewFiles","id":"CVE-2021-39186"},"products":["parse-server"],"published":"2021-09-02","related":[{"cvss_score":10,"headline":"Parse Server role escalation and CLP bypass via direct `_Join` table write","id":"CVE-2026-30966","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":10,"headline":"Parse Server literalizeRegexPart SQL Injection","id":"CVE-2024-27298","kev_date_added":null,"published":"2024-03-01"},{"cvss_score":10,"headline":"Command Injection in Parse server","id":"CVE-2022-24760","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":9.9,"headline":"Parse Server session token exfiltration via `redirectClassNameForKey` query parameter","id":"CVE-2026-30965","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":9.8,"headline":"Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution","id":"CVE-2023-36475","kev_date_added":null,"published":"2023-06-28"},{"cvss_score":9.8,"headline":"Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser","id":"CVE-2022-39396","kev_date_added":null,"published":"2022-11-10"},{"cvss_score":9.3,"headline":"Parse Server: Account takeover via operator injection in authentication data identifier","id":"CVE-2026-32248","kev_date_added":null,"published":"2026-03-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["parse-community"]},"summary":"An attacker can crash the Parse Server by sending a query with an invalid explain option, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2021-39187/"}