# CVE-2021-39187: Crash server with query parameter

> An attacker can crash the Parse Server by sending a query with an invalid explain option, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-parse-2021-39187, GHSA-xqp8-w826-hh6x

## What is CVE-2021-39187?

CVE-2021-39187 is a high-severity denial of service vulnerability in Parseplatform Parse-Server, published on 2 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to version 4.10.3, Parse Server crashes when if a query request contains an invalid value for the `explain` option. This is due to a bug in the MongoDB Node.js driver which throws an exception that Parse Server cannot catch. There is a patch for this issue in version 4.10.3. No workarounds aside from upgrading are known to exist.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2021-39187?

3 open source packages ship an affected version, including parse-server and parse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 4.10.3 |
| `parse-server` | npm | All versions | 4.10.3 |
| `parse` | Bitnami | All versions | 4.10.3 |

Products: Parseplatform Parse-Server.

## How do I fix CVE-2021-39187?

Upgrade parse-server to 4.10.3 or later.

## Is CVE-2021-39187 being exploited?

There is no known exploitation of CVE-2021-39187 in the wild and no public exploit code.

## Other vulnerabilities in Parseplatform Parse-Server

- [CVE-2026-30966](https://insights.sbomify.com/CVE-2026-30966/): Parse Server role escalation and CLP bypass via direct `_Join` table write (critical 10.0)
- [CVE-2024-27298](https://insights.sbomify.com/CVE-2024-27298/): Parse Server literalizeRegexPart SQL Injection (critical 10.0)
- [CVE-2022-24760](https://insights.sbomify.com/CVE-2022-24760/): Command Injection in Parse server (critical 10.0)
- [CVE-2026-30965](https://insights.sbomify.com/CVE-2026-30965/): Parse Server session token exfiltration via `redirectClassNameForKey` query parameter (critical 9.9)
- [CVE-2023-36475](https://insights.sbomify.com/CVE-2023-36475/): Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39187 and fix it if it is affected.

What it is: CVE-2021-39187 is a high-severity denial of service vulnerability in Parseplatform Parse-Server, published on 2 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39187 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 4.10.3
- parse-server (npm): affected all versions; fixed in 4.10.3
- parse (Bitnami): affected all versions; fixed in 4.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39187/ (Markdown: https://insights.sbomify.com/CVE-2021-39187/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39187
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39187
- OSV: https://osv.dev/vulnerability/CVE-2021-39187

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39187/
Summaries are generated and may contain mistakes; the official description above is the record.
