# CVE-2021-39190: SCCM plugin for GLPI vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

> An attacker can access the SCCM plugin configuration page in GLPI to view sensitive information without authentication.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 22 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-3324-57w6-jxcq

## What is CVE-2021-39190?

CVE-2021-39190 is a medium-severity vulnerability in pluginsGLPI sccm, published on 22 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The SCCM plugin for GLPI is a plugin to synchronize computers from SCCM (version 1802) to GLPI. In versions prior to 2.3.0, the Configuration page is publicly accessible in read-only mode. This issue is patched in version 2.3.0. No known workarounds exist.

Weakness: CWE-862 (Missing Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-39190?

It affects 1 product.


Products: Teclib-Edition System Center Configuration Manager.

## How do I fix CVE-2021-39190?

No fix has been published for CVE-2021-39190 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-39190 being exploited?

There is no known exploitation of CVE-2021-39190 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39190 and fix it if it is affected.

What it is: CVE-2021-39190 is a medium-severity vulnerability in pluginsGLPI sccm, published on 22 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39190 in the wild and no public exploit code.

Affected product: pluginsGLPI sccm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39190/ (Markdown: https://insights.sbomify.com/CVE-2021-39190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39190
- OSV: https://osv.dev/vulnerability/CVE-2021-39190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39190/
Summaries are generated and may contain mistakes; the official description above is the record.
