CVE-2021-39192 Privilege escalation: all users can access Admin-level API keys
Authenticated users can view admin-level API keys, enabling privilege escalation and unauthorized access to sensitive administrative functions.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-39192?
CVE-2021-39192 is a medium-severity vulnerability in TryGhost Ghost, published on 3 Sep 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Ghost is a Node.js content management system. An error in the implementation of the limits service between versions 4.0.0 and 4.9.4 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. This issue is patched in Ghost version 4.10.0. As a workaround, disable all non-Administrator accounts to prevent API access. It is highly recommended to regenerate all API keys after patching or applying the workaround.
Which versions are affected by CVE-2021-39192?
3 open source packages ship an affected version, including ghost. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
ghost Bitnami | From 4.0.0 | 4.10.0 |
ghost npm | From 4.0.0 | 4.10.0 |
ghost npm | From 4.0.0 | 4.10.0 |
Products include Ghost Ghost.
How do I fix CVE-2021-39192?
Upgrade ghost to 4.10.0 or later.
Is CVE-2021-39192 being exploited?
There is no known exploitation of CVE-2021-39192 in the wild and no public exploit code.
Other vulnerabilities in TryGhost Ghost
Sources
Also known as BIT-ghost-2021-39192, GHSA-j5c2-hm46-wp5c.