# CVE-2021-39194: Denial of service while parsing polymorphic input with tagged polymorphism style in kaml


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 7 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fmm9-3gv8-58f4

## What is CVE-2021-39194?

CVE-2021-39194 is a medium-severity vulnerability in charleskorn kaml, published on 7 Sep 2021. 

### Official description

kaml is an open source implementation of the YAML format with support for kotlinx.serialization. In affected versions attackers that could provide arbitrary YAML input to an application that uses kaml could cause the application to endlessly loop while parsing the input. This could result in resource starvation and denial of service. This only affects applications that use polymorphic serialization with the default tagged polymorphism style. Applications using the property polymorphism style are not affected. YAML input for a polymorphic type that provided a tag but no value for the object would trigger the issue. Version 0.35.3 or later contain the fix for this issue.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2021-39194?

2 open source packages ship an affected version, including com.charleskorn.kaml:kaml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.charleskorn.kaml:kaml` | Maven | All versions | 0.35.3 |
| `com.charleskorn.kaml:kaml` | Maven | All versions | 0.35.3 |

Products: Kaml Project Kaml.

## How do I fix CVE-2021-39194?

Upgrade com.charleskorn.kaml:kaml to 0.35.3 or later.

## Is CVE-2021-39194 being exploited?

There is no known exploitation of CVE-2021-39194 in the wild and no public exploit code.

## Other vulnerabilities in charleskorn kaml

- [CVE-2023-28118](https://insights.sbomify.com/CVE-2023-28118/): kaml has potential denial of service while parsing input with anchors and aliases (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39194 and fix it if it is affected.

What it is: CVE-2021-39194 is a medium-severity vulnerability in charleskorn kaml, published on 7 Sep 2021. 
Exploitation: There is no known exploitation of CVE-2021-39194 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.charleskorn.kaml:kaml (Maven): affected all versions; fixed in 0.35.3
- com.charleskorn.kaml:kaml (Maven): affected all versions; fixed in 0.35.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39194/ (Markdown: https://insights.sbomify.com/CVE-2021-39194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39194
- OSV: https://osv.dev/vulnerability/CVE-2021-39194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39194/
Summaries are generated and may contain mistakes; the official description above is the record.
