CVE-2021-39197 Cross-Site Request Forgery in better_errors
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2021-39197?
CVE-2021-39197 is a medium-severity vulnerability in BetterErrors better_errors, published on 7 Sep 2021.
Official description
better_errors is an open source replacement for the standard Rails error page with more information rich error pages. It is also usable outside of Rails in any Rack app as Rack middleware. better_errors prior to 2.8.0 did not implement CSRF protection for its internal requests. It also did not enforce the correct "Content-Type" header for these requests, which allowed a cross-origin "simple request" to be made without CORS protection. These together left an application with better_errors enabled open to cross-origin attacks. As a developer tool, better_errors documentation strongly recommends addition only to the `development` bundle group, so this vulnerability should only affect development environments. Please ensure that your project limits better_errors to the `development` group (or the non-Rails equivalent). Starting with release 2.8.x, CSRF protection is enforced. It is recommended that you upgrade to the latest release, or minimally to "~> 2.8.3". There are no known workarounds to mitigate the risk of using older releases of better_errors.
Weakness: CWE-352
Which versions are affected by CVE-2021-39197?
2 open source packages ship an affected version, including better_errors. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
better_errors RubyGems | All versions | 2.8.0 |
better_errors RubyGems | All versions | 2.8.0 |
Products include Better Errors Project Better Errors.
How do I fix CVE-2021-39197?
Upgrade better_errors to 2.8.0 or later.
Is CVE-2021-39197 being exploited?
There is no known exploitation of CVE-2021-39197 in the wild and no public exploit code.
Sources
Also known as GHSA-w3j4-76qw-wwjm.