CVE-2021-39200 Information Disclosure in wp_die() via JSONP in wordpress

Medium 5.3 Published Updated

Attackers can leak sensitive data like nonces via wp_die() JSONP output, enabling unauthorized actions on behalf of users.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39200?

CVE-2021-39200 is a medium-severity vulnerability in Debian Debian Linux, published on 9 Sep 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. In affected versions output data of the function wp_die() can be leaked under certain conditions, which can include data like nonces. It can then be used to perform actions on your behalf. This has been patched in WordPress 5.8.1, along with any older affected versions via minor releases. It's strongly recommended that you keep auto-updates enabled to receive the fix.

Weakness: CWE-200

Which versions are affected by CVE-2021-39200?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.

PackageAffectedFixed in
wordpress BitnamiFrom 5.2.05.8.1
wordpress-multisite BitnamiFrom 5.2.05.8.1

Products include Debian Debian Linux, Wordpress Wordpress.

How do I fix CVE-2021-39200?

Upgrade wordpress to 5.8.1 or later.

Is CVE-2021-39200 being exploited?

There is no known exploitation of CVE-2021-39200 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as BIT-wordpress-2021-39200, BIT-wordpress-multisite-2021-39200, DEBIAN-CVE-2021-39200, GHSA-m9hc-7v5q-x8q5, UBUNTU-CVE-2021-39200.

Is CVE-2021-39200 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free