CVE-2021-39201 Authenticated cross-site scripting (XSS) in WordPress editor
Authenticated low-privileged users can execute cross-site scripting in the WordPress editor, bypassing HTML filtering restrictions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-39201?
CVE-2021-39201 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 9 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. ### Impact The issue allows an authenticated but low-privileged user (like contributor/author) to execute XSS in the editor. This bypasses the restrictions imposed on users who do not have the permission to post `unfiltered_html`. ### Patches This has been patched in WordPress 5.8, and will be pushed to older versions via minor releases (automatic updates). It's strongly recommended that you keep auto-updates enabled to receive the fix. ### References https://wordpress.org/news/category/releases/ https://hackerone.com/reports/1142140 ### For more information If you have any questions or comments about this advisory: * Open an issue in [HackerOne](https://hackerone.com/wordpress)
Weakness: CWE-79
Which versions are affected by CVE-2021-39201?
2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
wordpress Bitnami | From 5.0.0 | 5.8.0 |
wordpress-multisite Bitnami | From 5.0.0 | 5.8.0 |
Products include Debian Debian Linux, Wordpress Wordpress.
How do I fix CVE-2021-39201?
Upgrade wordpress to 5.8.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-39201 being exploited?
There is no known exploitation of CVE-2021-39201 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-wordpress-2021-39201, BIT-wordpress-multisite-2021-39201, DEBIAN-CVE-2021-39201, DSA-4985-1, GHSA-wh69-25hr-h94v, UBUNTU-CVE-2021-39201.