{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-39201 in the wild and no public exploit code.","fix":"Upgrade wordpress to 5.8.0 or later.","what":"CVE-2021-39201 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 9 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-39201 and fix it if it is affected.\n\nWhat it is: CVE-2021-39201 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 9 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-39201 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected from 5.0.0; fixed in 5.8.0\n- wordpress-multisite (Bitnami): affected from 5.0.0; fixed in 5.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-39201/ (Markdown: https://insights.sbomify.com/CVE-2021-39201/index.md)","id":"CVE-2021-39201","markdown":"https://insights.sbomify.com/CVE-2021-39201/index.md","name":"CVE-2021-39201","record":{"aliases":["BIT-wordpress-2021-39201","BIT-wordpress-multisite-2021-39201","DEBIAN-CVE-2021-39201","DSA-4985-1","GHSA-wh69-25hr-h94v","UBUNTU-CVE-2021-39201"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress CMS","requires_auth":"low_privilege","summary":"Authenticated low-privileged users can execute cross-site scripting in the WordPress editor, bypassing HTML filtering restrictions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. ### Impact The issue allows an authenticated but low-privileged user (like contributor/author) to execute XSS in the editor. This bypasses the restrictions imposed on users who do not have the permission to post `unfiltered_html`. ### Patches This has been patched in WordPress 5.8, and will be pushed to older versions via minor releases (automatic updates). It's strongly recommended that you keep auto-updates enabled to receive the fix. ### References https://wordpress.org/news/category/releases/ https://hackerone.com/reports/1142140 ### For more information If you have any questions or comments about this advisory: * Open an issue in [HackerOne](https://hackerone.com/wordpress)","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authenticated cross-site scripting (XSS) in WordPress editor","id":"CVE-2021-39201","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","wordpress:wordpress"],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"WordPress 5.8 beta: Stored Cross-Site Scripting (XSS) vulnerability in widget","id":"CVE-2021-39202"},"packages":[{"ecosystem":"Bitnami","fixed":["5.8.0"],"introduced":["5.0.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2021-39201"},{"ecosystem":"Bitnami","fixed":["5.8.0"],"introduced":["5.0.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2021-39201"}],"prev":{"headline":"Information Disclosure in wp_die() via JSONP in wordpress","id":"CVE-2021-39200"},"products":["wordpress-develop"],"published":"2021-09-09","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["WordPress"]},"summary":"Authenticated low-privileged users can execute cross-site scripting in the WordPress editor, bypassing HTML filtering restrictions.","url":"https://insights.sbomify.com/CVE-2021-39201/"}