# CVE-2021-39201: Authenticated cross-site scripting (XSS) in WordPress editor

> Authenticated low-privileged users can execute cross-site scripting in the WordPress editor, bypassing HTML filtering restrictions.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-wordpress-2021-39201, BIT-wordpress-multisite-2021-39201, DEBIAN-CVE-2021-39201, DSA-4985-1, GHSA-wh69-25hr-h94v, UBUNTU-CVE-2021-39201

## What is CVE-2021-39201?

CVE-2021-39201 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 9 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

WordPress is a free and open-source content management system written in PHP and paired with a MySQL or MariaDB database. ### Impact The issue allows an authenticated but low-privileged user (like contributor/author) to execute XSS in the editor. This bypasses the restrictions imposed on users who do not have the permission to post `unfiltered_html`. ### Patches This has been patched in WordPress 5.8, and will be pushed to older versions via minor releases (automatic updates). It's strongly recommended that you keep auto-updates enabled to receive the fix. ### References https://wordpress.org/news/category/releases/ https://hackerone.com/reports/1142140 ### For more information If you have any questions or comments about this advisory: * Open an issue in [HackerOne](https://hackerone.com/wordpress)

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-39201?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | From 5.0.0 | 5.8.0 |
| `wordpress-multisite` | Bitnami | From 5.0.0 | 5.8.0 |

Products: Debian Debian Linux, Wordpress Wordpress.

## How do I fix CVE-2021-39201?

Upgrade wordpress to 5.8.0 or later.

## Is CVE-2021-39201 being exploited?

There is no known exploitation of CVE-2021-39201 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39201 and fix it if it is affected.

What it is: CVE-2021-39201 is a high-severity cross-site scripting vulnerability in Debian Debian Linux, published on 9 Sep 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-39201 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected from 5.0.0; fixed in 5.8.0
- wordpress-multisite (Bitnami): affected from 5.0.0; fixed in 5.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39201/ (Markdown: https://insights.sbomify.com/CVE-2021-39201/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39201
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39201
- OSV: https://osv.dev/vulnerability/CVE-2021-39201

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39201/
Summaries are generated and may contain mistakes; the official description above is the record.
