{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-39211 exists.","fix":"No fix has been published for CVE-2021-39211 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-39211 is a medium-severity vulnerability in Glpi-Project Glpi, published on 15 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-39211 and fix it if it is affected.\n\nWhat it is: CVE-2021-39211 is a medium-severity vulnerability in Glpi-Project Glpi, published on 15 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-39211 exists.\n\nAffected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-39211/ (Markdown: https://insights.sbomify.com/CVE-2021-39211/index.md)","id":"CVE-2021-39211","markdown":"https://insights.sbomify.com/CVE-2021-39211/index.md","name":"CVE-2021-39211","record":{"aliases":["GHSA-xx66-v3g5-w825","UBUNTU-CVE-2021-39211"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"IT asset management","requires_auth":"none","summary":"An attacker can access the telemetry endpoint to retrieve sensitive GLPI and server information, impacting confidentiality.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"glpi","vendor":"glpi-project"}],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"GLPI is a free Asset and IT management software package. Starting in version 9.2 and prior to version 9.5.6, the telemetry endpoint discloses GLPI and server information. This issue is fixed in version 9.5.6. As a workaround, remove the file `ajax/telemetry.php`, which is not needed for usual functions of GLPI.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2021/CVE-2021-39211.yaml","stars":null,"title":"GLPI 9.2/\u003c9.5.6 - Information Disclosure"}],"tier":"weaponised"},"has_fix":false,"headline":"Disclosure of GLPI and server information in telemetry endpoint","id":"CVE-2021-39211","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"glpi-project:glpi","products":["glpi-project:glpi"],"type":"information_disclosure","year":"2021"},"n_packages":0,"n_references":2,"next":{"headline":"Issue when Configuring the ImageMagick Security Policy","id":"CVE-2021-39212"},"packages":[],"prev":{"headline":"Autologin cookie accessible by scripts","id":"CVE-2021-39210"},"products":["glpi"],"published":"2021-09-15","related":[{"cvss_score":9.8,"headline":"Teclib GLPI Remote Code Execution","id":"CVE-2022-35914","kev_date_added":"2023-03-07","published":"2022-09-19"},{"cvss_score":10,"headline":"GLPI vulnerable to unallowed PHP script execution","id":"CVE-2023-42802","kev_date_added":null,"published":"2023-11-02"},{"cvss_score":10,"headline":"GLPI vulnerable to SQL injection and Stored XSS via inventory agent request","id":"CVE-2023-28849","kev_date_added":null,"published":"2023-04-05"},{"cvss_score":10,"headline":"SQL injection in GLPI","id":"CVE-2022-35947","kev_date_added":null,"published":"2022-09-14"},{"cvss_score":9.8,"headline":"SQL injection with _actor parameter in GLPI","id":"CVE-2022-31056","kev_date_added":null,"published":"2022-06-28"},{"cvss_score":9.8,"headline":"SQL injection on login page in GLPI","id":"CVE-2022-31061","kev_date_added":null,"published":"2022-06-28"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2021-44617","kev_date_added":null,"published":"2022-03-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["glpi-project"]},"summary":"An attacker can access the telemetry endpoint to retrieve sensitive GLPI and server information, impacting confidentiality.","url":"https://insights.sbomify.com/CVE-2021-39211/"}