# CVE-2021-39211: Disclosure of GLPI and server information in telemetry endpoint

> An attacker can access the telemetry endpoint to retrieve sensitive GLPI and server information, impacting confidentiality.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-xx66-v3g5-w825, UBUNTU-CVE-2021-39211

## What is CVE-2021-39211?

CVE-2021-39211 is a medium-severity vulnerability in Glpi-Project Glpi, published on 15 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GLPI is a free Asset and IT management software package. Starting in version 9.2 and prior to version 9.5.6, the telemetry endpoint discloses GLPI and server information. This issue is fixed in version 9.5.6. As a workaround, remove the file `ajax/telemetry.php`, which is not needed for usual functions of GLPI.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-39211?

It affects 1 product.


Products: Glpi-Project Glpi.

## How do I fix CVE-2021-39211?

No fix has been published for CVE-2021-39211 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-39211 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-39211 exists.

Public exploit code:

- GLPI 9.2/<9.5.6 - Information Disclosure (nuclei): http/cves/2021/CVE-2021-39211.yaml

## Other vulnerabilities in Glpi-Project Glpi

- [CVE-2022-35914](https://insights.sbomify.com/CVE-2022-35914/): Teclib GLPI Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2023-42802](https://insights.sbomify.com/CVE-2023-42802/): GLPI vulnerable to unallowed PHP script execution (critical 10.0)
- [CVE-2023-28849](https://insights.sbomify.com/CVE-2023-28849/): GLPI vulnerable to SQL injection and Stored XSS via inventory agent request (critical 10.0)
- [CVE-2022-35947](https://insights.sbomify.com/CVE-2022-35947/): SQL injection in GLPI (critical 10.0)
- [CVE-2022-31056](https://insights.sbomify.com/CVE-2022-31056/): SQL injection with _actor parameter in GLPI (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39211 and fix it if it is affected.

What it is: CVE-2021-39211 is a medium-severity vulnerability in Glpi-Project Glpi, published on 15 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-39211 exists.

Affected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39211/ (Markdown: https://insights.sbomify.com/CVE-2021-39211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39211
- OSV: https://osv.dev/vulnerability/CVE-2021-39211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39211/
Summaries are generated and may contain mistakes; the official description above is the record.
