CVE-2021-39213 IP restriction on GLPI API Bypass with custom header injection

Medium 6.8 Published Updated

Attackers can bypass IP restrictions on the GLPI API by injecting custom headers, allowing unauthorized access to the API.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2021-39213?

CVE-2021-39213 is a medium-severity vulnerability in Glpi-Project Glpi, published on 15 Sep 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

GLPI is a free Asset and IT management software package. Starting in version 9.1 and prior to version 9.5.6, GLPI with API Rest enabled is vulnerable to API bypass with custom header injection. This issue is fixed in version 9.5.6. One may disable API Rest as a workaround.

Weakness: CWE-74

Which versions are affected by CVE-2021-39213?

It affects 1 product.

Products include Glpi-Project Glpi.

How do I fix CVE-2021-39213?

No fix has been published for CVE-2021-39213 yet. Limit exposure of the affected software until one is available.

Is CVE-2021-39213 being exploited?

There is no known exploitation of CVE-2021-39213 in the wild and no public exploit code.

All Glpi-Project Glpi vulnerabilities

Sources

Also known as GHSA-6w9f-2m6g-5777, UBUNTU-CVE-2021-39213.

Is CVE-2021-39213 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free