# CVE-2021-39215: Authentication Bypass: Forged Tokens Allow Access to Arbitrary Rooms

> Attackers can use forged tokens to bypass authentication and access protected video conferencing rooms in Jitsi Meet.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Sep 2021
- **Updated:** 4 Aug 2024

## What is CVE-2021-39215?

CVE-2021-39215 is a high-severity authentication bypass vulnerability in jitsi-meet, published on 15 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jitsi Meet is an open source video conferencing application. In versions prior to 2.0.5963, a Prosody module allows the use of symmetrical algorithms to validate JSON web tokens. This means that tokens generated by arbitrary sources can be used to gain authorization to protected rooms. This issue is fixed in Jitsi Meet 2.0.5963. There are no known workarounds aside from updating.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-39215?

It affects 1 product.


Products: 8x8 Jitsi Meet.

## How do I fix CVE-2021-39215?

No fix has been published for CVE-2021-39215 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-39215 being exploited?

There is no known exploitation of CVE-2021-39215 in the wild and no public exploit code.

## Other vulnerabilities in jitsi-meet

- [CVE-2024-44081](https://insights.sbomify.com/CVE-2024-44081/): Cross-site scripting in n/a (critical 9.8)
- [CVE-2024-44080](https://insights.sbomify.com/CVE-2024-44080/): Cross-site scripting in n/a (high 7.5)
- [CVE-2021-33506](https://insights.sbomify.com/CVE-2021-33506/): Missing authorization in n/a (high 7.5)
- [CVE-2021-39205](https://insights.sbomify.com/CVE-2021-39205/): DOM-based XSS/Content Spoofing via Prototype Pollution (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39215 and fix it if it is affected.

What it is: CVE-2021-39215 is a high-severity authentication bypass vulnerability in jitsi-meet, published on 15 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39215 in the wild and no public exploit code.

Affected product: jitsi-meet. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39215/ (Markdown: https://insights.sbomify.com/CVE-2021-39215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39215
- OSV: https://osv.dev/vulnerability/CVE-2021-39215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39215/
Summaries are generated and may contain mistakes; the official description above is the record.
