CVE-2021-39217 OpenMage LTS arbitrary command execution in custom layout update through blocks

High 7.2 Published Updated

Admin users can execute arbitrary commands via block methods in OpenMage LTS when Custom Layout is enabled.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-39217?

CVE-2021-39217 is a high-severity command injection vulnerability in OpenMage magento-lts, published on 27 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, Custom Layout enabled admin users to execute arbitrary commands via block methods. Versions 19.4.22 and 20.0.19 contain patches for this issue.

Weakness: CWE-77

Which versions are affected by CVE-2021-39217?

4 open source packages ship an affected version, including openmage/magento-lts. It affects 1 product.

PackageAffectedFixed in
openmage/magento-lts PackagistAll versions19.4.22
openmage/magento-lts PackagistAll versions19.4.22
openmage/magento-lts PackagistFrom 20.0.020.0.19
openmage/magento-lts PackagistFrom 20.0.020.0.19

Products include Openmage Magento.

How do I fix CVE-2021-39217?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.22 or 20.0.19.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2021-39217 being exploited?

There is no known exploitation of CVE-2021-39217 in the wild and no public exploit code.

Sources

Also known as GHSA-c9q3-r4rv-mjm7.

Is CVE-2021-39217 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free