{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-39221 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-39221 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-39221 is a medium-severity cross-site scripting vulnerability in nextcloud security-advisories, published on 25 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-39221 and fix it if it is affected.\n\nWhat it is: CVE-2021-39221 is a medium-severity cross-site scripting vulnerability in nextcloud security-advisories, published on 25 Oct 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-39221 in the wild and no public exploit code.\n\nAffected product: nextcloud security-advisories. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-39221/ (Markdown: https://insights.sbomify.com/CVE-2021-39221/index.md)","id":"CVE-2021-39221","markdown":"https://insights.sbomify.com/CVE-2021-39221/index.md","name":"CVE-2021-39221","record":{"aliases":["GHSA-j6cx-mxqf-f9vc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Nextcloud Contacts app","requires_auth":"low_privilege","summary":"Stored XSS in Nextcloud Contacts allows attackers to execute scripts if users open malicious files in new tabs, mitigated by CSP on modern browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"contacts","vendor":"nextcloud"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"Nextcloud is an open-source, self-hosted productivity platform. The Nextcloud Contacts application prior to version 4.0.3 was vulnerable to a stored Cross-Site Scripting (XSS) vulnerability. For exploitation, a user would need to right-click on a malicious file and open the file in a new tab. Due the strict Content-Security-Policy shipped with Nextcloud, this issue is not exploitable on modern browsers supporting Content-Security-Policy. It is recommended that the Nextcloud Contacts application is upgraded to 4.0.3. As a workaround, one may use a browser that has support for Content-Security-Policy.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"XSS in Contacts","id":"CVE-2021-39221","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2021"},"n_packages":0,"n_references":2,"next":{"headline":"XSS in Talk","id":"CVE-2021-39222"},"packages":[],"prev":{"headline":"Bypass of image blocking in Nextcloud Mail","id":"CVE-2021-39220"},"products":["security-advisories"],"published":"2021-10-25","related":[{"cvss_score":5.4,"headline":"Cross-site scripting in Nextcloud Contacts","id":"CVE-2020-8280","kev_date_added":null,"published":"2021-01-06"},{"cvss_score":5.4,"headline":"Cross-site scripting in Nextcloud Contacts","id":"CVE-2020-8281","kev_date_added":null,"published":"2021-01-06"},{"cvss_score":4.8,"headline":"Cross-site scripting in Nextcloud Contacts application","id":"CVE-2018-3764","kev_date_added":null,"published":"2018-07-05"},{"cvss_score":4.3,"headline":"File upload in Nextcloud Contact","id":"CVE-2020-8181","kev_date_added":null,"published":"2020-07-10"},{"cvss_score":3.5,"headline":"Nextcloud Contacts vulnerable to Stored XSS in contacts app via organisation and title field","id":"CVE-2025-66554","kev_date_added":null,"published":"2025-12-05"},{"cvss_score":0,"headline":"Nextcloud Contacts photos only sanitized if mime type is all lower case","id":"CVE-2023-33182","kev_date_added":null,"published":"2023-05-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["nextcloud"]},"summary":"Stored XSS in Nextcloud Contacts allows attackers to execute scripts if users open malicious files in new tabs, mitigated by CSP on modern browsers.","url":"https://insights.sbomify.com/CVE-2021-39221/"}