# CVE-2021-39228: Memory Safety Issue when using patch or merge on state and assign the result back to state

> Attackers can trigger memory corruption in Tremor by exploiting a use-after-free bug in state patching, potentially leading to code execution or data exposure.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mc22-5q92-8v85

## What is CVE-2021-39228?

CVE-2021-39228 is a medium-severity use after free vulnerability in tremor-rs tremor-runtime, published on 17 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tremor is an event processing system for unstructured data. A vulnerability exists between versions 0.7.2 and 0.11.6. This vulnerability is a memory safety Issue when using `patch` or `merge` on `state` and assign the result back to `state`. In this case, affected versions of Tremor and the tremor-script crate maintains references to memory that might have been freed already. And these memory regions can be accessed by retrieving the `state`, e.g. send it over TCP or HTTP. This requires the Tremor server (or any other program using tremor-script) to execute a tremor-script script that uses the mentioned language construct. The issue has been patched in version 0.11.6 by removing the optimization and always cloning the target expression of a Merge or Patch. If an upgrade is not possible, a possible workaround is to avoid the optimization by introducing a temporary variable and not immediately reassigning to `state`.

Weakness: CWE-825 (Expired Pointer Dereference), CWE-416 (Use After Free)

## Which versions are affected by CVE-2021-39228?

2 open source packages ship an affected version, including tremor-script. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tremor-script` | crates.io | From 0.7.3 | 0.11.6 |
| `tremor-script` | crates.io | From 0.7.3 | 0.11.6 |

Products: Linuxfoundation Tremor.

## How do I fix CVE-2021-39228?

Upgrade tremor-script to 0.11.6 or later.

## Is CVE-2021-39228 being exploited?

There is no known exploitation of CVE-2021-39228 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39228 and fix it if it is affected.

What it is: CVE-2021-39228 is a medium-severity use after free vulnerability in tremor-rs tremor-runtime, published on 17 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39228 in the wild and no public exploit code.

Affected packages and fixed versions:
- tremor-script (crates.io): affected from 0.7.3; fixed in 0.11.6
- tremor-script (crates.io): affected from 0.7.3; fixed in 0.11.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39228/ (Markdown: https://insights.sbomify.com/CVE-2021-39228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39228
- OSV: https://osv.dev/vulnerability/CVE-2021-39228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39228/
Summaries are generated and may contain mistakes; the official description above is the record.
