{"answers":{"affected":"3 open source packages ship an affected version, including apprise. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-39229 in the wild and no public exploit code.","fix":"Upgrade apprise to 0.9.5.1 or later.","what":"CVE-2021-39229 is a high-severity denial of service vulnerability in caronc apprise, published on 20 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-39229 and fix it if it is affected.\n\nWhat it is: CVE-2021-39229 is a high-severity denial of service vulnerability in caronc apprise, published on 20 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-39229 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apprise (PyPI): affected all versions; fixed in 0.9.5.1\n- apprise (PyPI): affected all versions; fixed in 0.9.5.1\n- apprise (PyPI): affected all versions; fixed in 0.9.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-39229/ (Markdown: https://insights.sbomify.com/CVE-2021-39229/index.md)","id":"CVE-2021-39229","markdown":"https://insights.sbomify.com/CVE-2021-39229/index.md","name":"CVE-2021-39229","record":{"aliases":["GHSA-qhmp-h54x-38qr","PYSEC-2021-327"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python notification library","requires_auth":"none","summary":"Attackers can cause denial of service in the Apprise library via inefficient regular expressions in the IFTTT plugin, affecting users sending notifications.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"apprise","vendor":"nuxref"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is [here](https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359). The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove `apprise/plugins/NotifyIFTTT.py` to eliminate the service.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular expression deinal of service in apprise","id":"CVE-2021-39229","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":3,"n_references":3,"next":{"headline":"Error in JPNS kernel of Butter","id":"CVE-2021-39230"},"packages":[{"ecosystem":"PyPI","fixed":["0.9.5.1"],"introduced":["0"],"last_affected":[],"package":"apprise","purl":null,"source":"GHSA-qhmp-h54x-38qr"},{"ecosystem":"PyPI","fixed":["0.9.5.1"],"introduced":["0"],"last_affected":[],"package":"apprise","purl":"pkg:pypi/apprise","source":"GHSA-qhmp-h54x-38qr"},{"ecosystem":"PyPI","fixed":["0.9.5.1"],"introduced":["0"],"last_affected":[],"package":"apprise","purl":"pkg:pypi/apprise","source":"PYSEC-2021-327"}],"prev":{"headline":"Memory Safety Issue when using patch or merge on state and assign the result back to state","id":"CVE-2021-39228"},"products":["apprise"],"published":"2021-09-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["caronc"]},"summary":"Attackers can cause denial of service in the Apprise library via inefficient regular expressions in the IFTTT plugin, affecting users sending notifications.","url":"https://insights.sbomify.com/CVE-2021-39229/"}