# CVE-2021-39229: Regular expression deinal of service in apprise

> Attackers can cause denial of service in the Apprise library via inefficient regular expressions in the IFTTT plugin, affecting users sending notifications.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qhmp-h54x-38qr, PYSEC-2021-327

## What is CVE-2021-39229?

CVE-2021-39229 is a high-severity denial of service vulnerability in caronc apprise, published on 20 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. In affected versions users who use Apprise granting them access to the IFTTT plugin (which just comes out of the box) are subject to a denial of service attack on an inefficient regular expression. The vulnerable regular expression is [here](https://github.com/caronc/apprise/blob/0007eade20934ddef0aba38b8f1aad980cfff253/apprise/plugins/NotifyIFTTT.py#L356-L359). The problem has been patched in release version 0.9.5.1. Users who are unable to upgrade are advised to remove `apprise/plugins/NotifyIFTTT.py` to eliminate the service.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-39229?

3 open source packages ship an affected version, including apprise. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apprise` | PyPI | All versions | 0.9.5.1 |
| `apprise` | PyPI | All versions | 0.9.5.1 |
| `apprise` | PyPI | All versions | 0.9.5.1 |

Products: Nuxref Apprise.

## How do I fix CVE-2021-39229?

Upgrade apprise to 0.9.5.1 or later.

## Is CVE-2021-39229 being exploited?

There is no known exploitation of CVE-2021-39229 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39229 and fix it if it is affected.

What it is: CVE-2021-39229 is a high-severity denial of service vulnerability in caronc apprise, published on 20 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39229 in the wild and no public exploit code.

Affected packages and fixed versions:
- apprise (PyPI): affected all versions; fixed in 0.9.5.1
- apprise (PyPI): affected all versions; fixed in 0.9.5.1
- apprise (PyPI): affected all versions; fixed in 0.9.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39229/ (Markdown: https://insights.sbomify.com/CVE-2021-39229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39229
- OSV: https://osv.dev/vulnerability/CVE-2021-39229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39229/
Summaries are generated and may contain mistakes; the official description above is the record.
