CVE-2021-39240 Other in n/a
HAProxy fails to validate URI scheme and path characters, potentially allowing routing rules to be bypassed or misinterpreted by backend servers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-39240?
CVE-2021-39240 is a high-severity vulnerability in Debian Debian Linux, published on 17 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in HAProxy 2.2 before 2.2.16, 2.3 before 2.3.13, and 2.4 before 2.4.3. It does not ensure that the scheme and path portions of a URI have the expected characters. For example, the authority field (as observed on a target HTTP/2 server) might differ from what the routing rules were intended to achieve.
Which versions are affected by CVE-2021-39240?
1 open source package ship an affected version, including haproxy. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
haproxy Bitnami | From 2.2.0 | 2.2.16, 2.3.13, 2.4.3 |
Products include Debian Debian Linux, Fedoraproject Fedora, Haproxy Haproxy.
How do I fix CVE-2021-39240?
Upgrade haproxy to a fixed version for your release line: 2.2.16, 2.3.13 or 2.4.3.
Is CVE-2021-39240 being exploited?
There is no known exploitation of CVE-2021-39240 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-haproxy-2021-39240, DEBIAN-CVE-2021-39240, GHSA-88gq-424p-x3xc.