{"answers":{"affected":"1 open source package ship an affected version, including haproxy. It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-39240 in the wild and no public exploit code.","fix":"Upgrade haproxy to a fixed version for your release line: 2.2.16, 2.3.13 or 2.4.3.","what":"CVE-2021-39240 is a high-severity vulnerability in Debian Debian Linux, published on 17 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-39240 and fix it if it is affected.\n\nWhat it is: CVE-2021-39240 is a high-severity vulnerability in Debian Debian Linux, published on 17 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-39240 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- haproxy (Bitnami): affected from 2.2.0; fixed in 2.2.16, 2.3.13, 2.4.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-39240/ (Markdown: https://insights.sbomify.com/CVE-2021-39240/index.md)","id":"CVE-2021-39240","markdown":"https://insights.sbomify.com/CVE-2021-39240/index.md","name":"CVE-2021-39240","record":{"aliases":["BIT-haproxy-2021-39240","DEBIAN-CVE-2021-39240","GHSA-88gq-424p-x3xc"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"HAProxy load balancer","requires_auth":"none","summary":"HAProxy fails to validate URI scheme and path characters, potentially allowing routing rules to be bypassed or misinterpreted by backend servers.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"haproxy","vendor":"haproxy"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[],"description":"An issue was discovered in HAProxy 2.2 before 2.2.16, 2.3 before 2.3.13, and 2.4 before 2.4.3. It does not ensure that the scheme and path portions of a URI have the expected characters. For example, the authority field (as observed on a target HTTP/2 server) might differ from what the routing rules were intended to achieve.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Other in n/a","id":"CVE-2021-39240","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":"other","year":"2021"},"n_packages":1,"n_references":6,"next":{"headline":"Other in n/a","id":"CVE-2021-39241"},"packages":[{"ecosystem":"Bitnami","fixed":["2.2.16","2.3.13","2.4.3"],"introduced":["2.2.0","2.3.0","2.4.0"],"last_affected":[],"package":"haproxy","purl":"pkg:bitnami/haproxy","source":"BIT-haproxy-2021-39240"}],"prev":{"headline":"XML External Entity (XXE) vulnerability","id":"CVE-2021-39239"},"products":["n/a"],"published":"2021-08-17","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"HAProxy fails to validate URI scheme and path characters, potentially allowing routing rules to be bypassed or misinterpreted by backend servers.","url":"https://insights.sbomify.com/CVE-2021-39240/"}