# CVE-2021-39240: Other in n/a

> HAProxy fails to validate URI scheme and path characters, potentially allowing routing rules to be bypassed or misinterpreted by backend servers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-haproxy-2021-39240, DEBIAN-CVE-2021-39240, GHSA-88gq-424p-x3xc

## What is CVE-2021-39240?

CVE-2021-39240 is a high-severity vulnerability in Debian Debian Linux, published on 17 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in HAProxy 2.2 before 2.2.16, 2.3 before 2.3.13, and 2.4 before 2.4.3. It does not ensure that the scheme and path portions of a URI have the expected characters. For example, the authority field (as observed on a target HTTP/2 server) might differ from what the routing rules were intended to achieve.

## Which versions are affected by CVE-2021-39240?

1 open source package ship an affected version, including haproxy. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haproxy` | Bitnami | From 2.2.0 | 2.2.16, 2.3.13, 2.4.3 |

Products: Debian Debian Linux, Fedoraproject Fedora, Haproxy Haproxy.

## How do I fix CVE-2021-39240?

Upgrade haproxy to a fixed version for your release line: 2.2.16, 2.3.13 or 2.4.3.

## Is CVE-2021-39240 being exploited?

There is no known exploitation of CVE-2021-39240 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39240 and fix it if it is affected.

What it is: CVE-2021-39240 is a high-severity vulnerability in Debian Debian Linux, published on 17 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39240 in the wild and no public exploit code.

Affected packages and fixed versions:
- haproxy (Bitnami): affected from 2.2.0; fixed in 2.2.16, 2.3.13, 2.4.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39240/ (Markdown: https://insights.sbomify.com/CVE-2021-39240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39240
- OSV: https://osv.dev/vulnerability/CVE-2021-39240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39240/
Summaries are generated and may contain mistakes; the official description above is the record.
