CVE-2021-39241 Other in n/a
Attackers can bypass access controls by crafting HTTP method names containing spaces and protected resource paths, potentially accessing restricted areas.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-39241?
CVE-2021-39241 is a medium-severity vulnerability in Debian Debian Linux, published on 17 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in HAProxy 2.0 before 2.0.24, 2.2 before 2.2.16, 2.3 before 2.3.13, and 2.4 before 2.4.3. An HTTP method name may contain a space followed by the name of a protected resource. It is possible that a server would interpret this as a request for that protected resource, such as in the "GET /admin? HTTP/1.1 /static/images HTTP/1.1" example.
Which versions are affected by CVE-2021-39241?
1 open source package ship an affected version, including haproxy. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
haproxy Bitnami | From 2.0.0 | 2.0.24, 2.2.16, 2.3.13, 2.4.3 |
Products include Debian Debian Linux, Fedoraproject Fedora, Haproxy Haproxy.
How do I fix CVE-2021-39241?
Upgrade haproxy to a fixed version for your release line: 2.0.24, 2.2.16, 2.3.13 or 2.4.3.
Is CVE-2021-39241 being exploited?
There is no known exploitation of CVE-2021-39241 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-haproxy-2021-39241, DEBIAN-CVE-2021-39241, GHSA-6x47-wc8c-3q36, UBUNTU-CVE-2021-39241, USN-5042-1.