{"answers":{"affected":"3 open source packages ship an affected version, including pywb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-39286 in the wild and no public exploit code.","fix":"Upgrade pywb to 2.6.0 or later.","what":"CVE-2021-39286 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-39286 and fix it if it is affected.\n\nWhat it is: CVE-2021-39286 is a medium-severity cross-site scripting vulnerability in n/a, published on 18 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-39286 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pywb (PyPI): affected all versions; fixed in 2.6.0\n- pywb (PyPI): affected all versions; fixed in 2.6.0\n- pywb (PyPI): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-39286/ (Markdown: https://insights.sbomify.com/CVE-2021-39286/index.md)","id":"CVE-2021-39286","markdown":"https://insights.sbomify.com/CVE-2021-39286/index.md","name":"CVE-2021-39286","record":{"aliases":["GHSA-947x-pv47-pp3q","PYSEC-2021-120"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python web archiving library","requires_auth":"none","summary":"Cross-site scripting vulnerability in pywb allows attackers to execute arbitrary scripts due to missing autoescaping in Jinja2 templates.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pywb","vendor":"webrecorder"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Webrecorder pywb before 2.6.0 allows XSS because it does not ensure that Jinja2 templates are autoescaped.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in pywb","id":"CVE-2021-39286","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"Hardcoded credentials in n/a","id":"CVE-2021-39289"},"packages":[{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"pywb","purl":null,"source":"GHSA-947x-pv47-pp3q"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"pywb","purl":"pkg:pypi/pywb","source":"GHSA-947x-pv47-pp3q"},{"ecosystem":"PyPI","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"pywb","purl":"pkg:pypi/pywb","source":"PYSEC-2021-120"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-39285"},"products":["n/a"],"published":"2021-08-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Cross-site scripting vulnerability in pywb allows attackers to execute arbitrary scripts due to missing autoescaping in Jinja2 templates.","url":"https://insights.sbomify.com/CVE-2021-39286/"}