# CVE-2021-39293: Denial of service in n/a

> A crafted zip archive header causes a panic in the Go standard library, leading to denial of service for applications using the archive/zip package.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2022
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-golang-2021-39293, DEBIAN-CVE-2021-39293, GHSA-j532-8pqq-78jr, GO-2022-0273, OESA-2022-1518, SUSE-RU-2021:3315-1, SUSE-SU-2021:3292-1, UBUNTU-CVE-2021-39293, openSUSE-SU-2021:1342-1, openSUSE-SU-2021:3292-1, openSUSE-SU-2024:10810-1

## What is CVE-2021-39293?

CVE-2021-39293 is a high-severity denial of service vulnerability in Golang Go, published on 24 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In archive/zip in Go before 1.16.8 and 1.17.x before 1.17.1, a crafted archive header (falsely designating that many files are present) can cause a NewReader or OpenReader panic. NOTE: this issue exists because of an incomplete fix for CVE-2021-33196.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2021-39293?

2 open source packages ship an affected version, including golang and stdlib. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `golang` | Bitnami | All versions | 1.16.8, 1.17.1 |
| `stdlib` | Go | All versions | 1.16.8, 1.17.1 |
| `go1.16` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 1.16.8-1.26.1 |
| `go1.17` | SUSE:Linux Enterprise Module for Development Tools 15 SP2 | All versions | 1.17.1-1.3.1 |
| `go1.16` | SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 1.16.8-1.26.1 |
| `go1.17` | SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 1.17.1-1.3.1 |
| `go1.16` | openSUSE:Leap 15.2 | All versions | 1.16.8-lp152.11.1 |
| `go1.16` | openSUSE:Leap 15.3 | All versions | 1.16.8-1.26.1 |
| `go1.17` | openSUSE:Tumbleweed | All versions | 1.17.1-1.1 |

Products: Golang Go, Netapp Cloud Insights Telegraf.

## How do I fix CVE-2021-39293?

Upgrade golang to a fixed version for your release line: 1.16.8 or 1.17.1.

## Is CVE-2021-39293 being exploited?

There is no known exploitation of CVE-2021-39293 in the wild and no public exploit code.

## Other vulnerabilities in Golang Go

- [CVE-2020-0601](https://insights.sbomify.com/CVE-2020-0601/): Microsoft Windows CryptoAPI Spoofing (high 8.1, exploited in the wild)
- [CVE-2026-27143](https://insights.sbomify.com/CVE-2026-27143/): Missing bound checks can lead to memory corruption in safe Go in cmd/compile (critical 9.8)
- [CVE-2024-24790](https://insights.sbomify.com/CVE-2024-24790/): Unexpected behavior from Is methods for IPv4-mapped IPv6 addresses in net/netip (critical 9.8)
- [CVE-2023-39320](https://insights.sbomify.com/CVE-2023-39320/): Arbitrary code execution via go.mod toolchain directive in cmd/go (critical 9.8)
- [CVE-2023-24540](https://insights.sbomify.com/CVE-2023-24540/): Improper handling of JavaScript whitespace in html/template (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39293 and fix it if it is affected.

What it is: CVE-2021-39293 is a high-severity denial of service vulnerability in Golang Go, published on 24 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-39293 in the wild and no public exploit code.

Affected packages and fixed versions:
- golang (Bitnami): affected all versions; fixed in 1.16.8, 1.17.1
- stdlib (Go): affected all versions; fixed in 1.16.8, 1.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39293/ (Markdown: https://insights.sbomify.com/CVE-2021-39293/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39293
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39293
- OSV: https://osv.dev/vulnerability/CVE-2021-39293

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39293/
Summaries are generated and may contain mistakes; the official description above is the record.
