{"answers":{"affected":"1 open source package ship an affected version, including pgbouncer. It affects 4 products.","exploited":"There is no known exploitation of CVE-2021-3935 in the wild and no public exploit code.","fix":"Upgrade pgbouncer to 1.16.1 or later.","what":"CVE-2021-3935 is a high-severity SQL injection vulnerability in Debian Debian Linux, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3935 and fix it if it is affected.\n\nWhat it is: CVE-2021-3935 is a high-severity SQL injection vulnerability in Debian Debian Linux, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3935 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pgbouncer (Bitnami): affected all versions; fixed in 1.16.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3935/ (Markdown: https://insights.sbomify.com/CVE-2021-3935/index.md)","id":"CVE-2021-3935","markdown":"https://insights.sbomify.com/CVE-2021-3935/index.md","name":"CVE-2021-3935","record":{"aliases":["BIT-pgbouncer-2021-3935","CLEANSTART-2026-MZ91907","DEBIAN-CVE-2021-3935","DLA-2922-1","GHSA-jh4v-gqwq-hfrr","UBUNTU-CVE-2021-3935"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"PgBouncer connection pooler","requires_auth":"none","summary":"A man-in-the-middle attacker can inject arbitrary SQL queries during connection establishment in PgBouncer when cert authentication is enabled.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"fedora","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"pgbouncer","vendor":"pgbouncer"},{"product":"enterprise_linux","vendor":"redhat"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"},{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"When PgBouncer is configured to use \"cert\" authentication, a man-in-the-middle attacker can inject arbitrary SQL queries when a connection is first established, despite the use of TLS certificate verification and encryption. This flaw affects PgBouncer versions prior to 1.16.1.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQL injection in pgbouncer","id":"CVE-2021-3935","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","redhat:enterprise_linux"],"type":"sql_injection","year":"2021"},"n_packages":1,"n_references":4,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2021-3937"},"packages":[{"ecosystem":"Bitnami","fixed":["1.16.1"],"introduced":["0"],"last_affected":[],"package":"pgbouncer","purl":"pkg:bitnami/pgbouncer","source":"BIT-pgbouncer-2021-3935"}],"prev":{"headline":"OS Command Injection in ohmyzsh/ohmyzsh","id":"CVE-2021-3934"},"products":["pgbouncer"],"published":"2021-11-22","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-11-03","vendors":["n/a"]},"summary":"A man-in-the-middle attacker can inject arbitrary SQL queries during connection establishment in PgBouncer when cert authentication is enabled.","url":"https://insights.sbomify.com/CVE-2021-3935/"}