CVE-2021-39371 XML External Entity Injection in PyWPS
An XML external entity injection in PyWPS allows attackers to read arbitrary files from the server filesystem.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-39371?
CVE-2021-39371 is a high-severity vulnerability in Debian Debian Linux, published on 23 Aug 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An XML external entity (XXE) injection in PyWPS before 4.4.5 allows an attacker to view files on the application server filesystem by assigning a path to the entity. OWSLib 0.24.1 may also be affected.
Weakness: CWE-611
Which versions are affected by CVE-2021-39371?
3 open source packages ship an affected version, including pywps. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
pywps PyPI | All versions | 4.5.0 |
pywps PyPI | All versions | 4.5.0 |
pywps PyPI | All versions | 4.5.0 |
Products include Debian Debian Linux, Osgeo Owslib, Osgeo Pywps.
How do I fix CVE-2021-39371?
Upgrade pywps to 4.5.0 or later.
Is CVE-2021-39371 being exploited?
There is no known exploitation of CVE-2021-39371 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2021-39371, DLA-2754-1, GHSA-p9wf-3xpg-c9g5, PYSEC-2021-121, UBUNTU-CVE-2021-39371.