CVE-2021-3943 Moodle vulnerable to RCE via unsafe deserialization

Critical 9.8 Published Updated

Attackers can achieve remote code execution by exploiting a flaw in Moodle's backup file restoration process.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-3943?

CVE-2021-3943 is a critical code injection vulnerability in Moodle Moodle, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A flaw was found in Moodle in versions 3.11 to 3.11.3, 3.10 to 3.10.7, 3.9 to 3.9.10 and earlier unsupported versions. A remote code execution risk when restoring backup files was identified.

Weakness: CWE-20

Which versions are affected by CVE-2021-3943?

7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 3.103.10.8
moodle/moodle PackagistFrom 3.103.10.8
moodle/moodle PackagistFrom 3.113.11.4
moodle/moodle PackagistFrom 3.113.11.4
moodle/moodle PackagistFrom 3.93.9.11
moodle/moodle PackagistFrom 3.93.9.11
1 more packages
moodle BitnamiFrom 3.9.03.9.11, 3.10.8, 3.11.4

Products include Moodle Moodle.

How do I fix CVE-2021-3943?

Upgrade moodle/moodle to a fixed version for your release line: 3.10.8, 3.11.4 or 3.9.11.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2021-3943 being exploited?

There is no known exploitation of CVE-2021-3943 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as BIT-moodle-2021-3943, GHSA-8jhp-2gcr-qw96, UBUNTU-CVE-2021-3943.

Is CVE-2021-3943 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free