# CVE-2021-39432: diplib Double Free

> A double free vulnerability in diplib allows attackers to cause denial of service or potentially execute arbitrary code.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Nov 2022
- **Updated:** 2 May 2025
- **Also known as:** GHSA-xf2w-5673-h6ww

## What is CVE-2021-39432?

CVE-2021-39432 is a medium-severity use after free vulnerability in n/a, published on 4 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

diplib v3.0.0 is vulnerable to Double Free.

Weakness: CWE-415 (Double Free), CWE-416 (Use After Free)

## Which versions are affected by CVE-2021-39432?

2 open source packages ship an affected version, including diplib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `diplib` | PyPI | All versions | 3.1.0 |
| `diplib` | PyPI | All versions | 3.1.0 |

Products: Diplib Diplib.

## How do I fix CVE-2021-39432?

Upgrade diplib to 3.1.0 or later.

## Is CVE-2021-39432 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-39432 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-39432 and fix it if it is affected.

What it is: CVE-2021-39432 is a medium-severity use after free vulnerability in n/a, published on 4 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-39432 exists.

Affected packages and fixed versions:
- diplib (PyPI): affected all versions; fixed in 3.1.0
- diplib (PyPI): affected all versions; fixed in 3.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-39432/ (Markdown: https://insights.sbomify.com/CVE-2021-39432/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-39432
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-39432
- OSV: https://osv.dev/vulnerability/CVE-2021-39432

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-39432/
Summaries are generated and may contain mistakes; the official description above is the record.
