# CVE-2021-3944: Cross-Site Request Forgery (CSRF) in bookstackapp/bookstack

> An attacker can trick authenticated users into performing unintended actions in BookStack, potentially modifying data or changing settings.

- **Severity:** Low 3.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Dec 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-wc7v-77jr-5c3m

## What is CVE-2021-3944?

CVE-2021-3944 is a low-severity vulnerability in bookstackapp/bookstack, published on 2 Dec 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

bookstack is vulnerable to Cross-Site Request Forgery (CSRF)

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-3944?

2 open source packages ship an affected version, including ssddanbrown/bookstack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ssddanbrown/bookstack` | Packagist | All versions | 21.11 |
| `ssddanbrown/bookstack` | Packagist | All versions | 21.11 |

Products: Bookstackapp Bookstack.

## How do I fix CVE-2021-3944?

Upgrade ssddanbrown/bookstack to 21.11 or later.

## Is CVE-2021-3944 being exploited?

There is no known exploitation of CVE-2021-3944 in the wild and no public exploit code.

## Other vulnerabilities in bookstackapp/bookstack

- [CVE-2020-5256](https://insights.sbomify.com/CVE-2020-5256/): Remote Code Execution Through Image Uploads in BookStack (high 7.9)
- [CVE-2020-26210](https://insights.sbomify.com/CVE-2020-26210/): Cross-Site Scripting in BookStack (high 7.7)
- [CVE-2020-26211](https://insights.sbomify.com/CVE-2020-26211/): Cross-Site Scripting in BookStack (high 7.7)
- [CVE-2022-0877](https://insights.sbomify.com/CVE-2022-0877/): Cross-site Scripting (XSS) - Stored in bookstackapp/bookstack (high 7.6)
- [CVE-2021-3915](https://insights.sbomify.com/CVE-2021-3915/): Unrestricted Upload of File with Dangerous Type in bookstackapp/bookstack (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3944 and fix it if it is affected.

What it is: CVE-2021-3944 is a low-severity vulnerability in bookstackapp/bookstack, published on 2 Dec 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-3944 in the wild and no public exploit code.

Affected packages and fixed versions:
- ssddanbrown/bookstack (Packagist): affected all versions; fixed in 21.11
- ssddanbrown/bookstack (Packagist): affected all versions; fixed in 21.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3944/ (Markdown: https://insights.sbomify.com/CVE-2021-3944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3944
- OSV: https://osv.dev/vulnerability/CVE-2021-3944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3944/
Summaries are generated and may contain mistakes; the official description above is the record.
